Skip to Content
avatar image
Former Member

too many PRIV processes

A month ago I have started to see too many PRIV processes in SM50.

I have only R/3 with Oracle 10.2 ECC 6.0 in an HP-UX with 16Gb RAM.

Why the performance started to worsen ?

Is it possible I have to increase one of these parameters ?

Or maybe there is something wrong in them ?

abap/heap_area_dia = 4000000000

abap/heap_area_nondia = 4000000000

abap/heap_area_total = 8000000000

abap/heaplimit = 20000000

abap/buffersize = 500000

em/initial_size_MB = 1200

em/stat_log_size_MB = 20

em/stat_log_timeout = 600

rdisp/PG_SHM = 8192

rdisp/ROLL_SHM = 16384

rdisp/ROLL_MAXFS = 32768

rdisp/PG_MAXFS = 32768

rtbb/buffer_length = 30000

rtbb/max_tables = 800

sap/bufdir_entries = 7500

zcsa/db_max_buftab = 10000

zcsa/presentation_buffer_area = 3000

zcsa/table_buffer_area = 50000000

ztta/roll_first = 1

ztta/roll_area = 6500000

ztta/roll_extension = 500000000

ztta/parameter_area = 8000

I would like very much to thank you for your help.

Albe.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

8 Answers

  • Best Answer
    Nov 11, 2013 at 04:32 PM

    Hello Albe,

    As mentioned by Reagan, a DIA workprocess will start to use HEAP memory as soon as it's EXTENDED MEMORY quota (ztta/roll_extension) is depleted. Then, it will use HEAP until abap/heap_area_dia is depleted.

    Once it starts to use HEAP memory, work process enters PRIV mode because the allocated memory will be released only when it restarts, this after it's task is done.

    Your current configuration for HEAP is very good:

    abap/heap_area_dia = 4000000000

    abap/heap_area_nondia = 4000000000

    abap/heap_area_total = 8000000000

    Your settings for EM though are undersized and need correction, therefore you'll have many PRIVs:

    ztta/roll_extension = 500000000 <-- Undersized. SAP reccomends 2gb minimum. (current 500Mb)

    em/initial_size_MB = 1200 <-- Undersized. SAP reccomends 2gb minimum (4Gb even better)

    Cheers,

    Ian Segóbio.


    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 07, 2013 at 12:57 PM

    Hi,

    I thing you have missed one 0 in this.

    em/initial_size_MB = 1200

    This is 1.2 gb not 12 gb.

    Thanks

    Rishi Abrol

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 07, 2013 at 03:07 PM

    Hi Albe,

    Check with customer on what they are trying to RUN.

    So you will get an idea on whats causing these PRIV mode.

    later you can think of adaption suggestions made by ashish above on

    rdisp/wppriv_max_no and rdisp/max_priv_time

    Then go for checking the memory defined for different parameters.

    Regards,

    Ravi

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 07, 2013 at 07:46 PM

    Hello

    ztta/roll_extension = 500000000

    The extended memory configured on the system is not according to the recommendations.

    I believe you know when a work process gets into a PRIV mode.

    http://help.sap.com/saphelp_nwpi71/helpdata/en/7a/caa6f3bfdb11d188b30000e83539c3/content.htm

    First configure the ztta/roll_extension to a suggested value

    Check this SAP note

    146289 - Parameter Recommendations for 64-Bit SAP Kernel

    Regards

    RB

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 07, 2013 at 09:36 PM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 07, 2013 at 01:44 PM

    Also you can use parameters rdisp/wppriv_max_no and rdisp/max_priv_time

    http://help.sap.com/saphelp_nw2004s/helpdata/en/7a/caa6f3bfdb11d188b30000e83539c3/content.htm

    best regards

    ashish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 12, 2013 at 08:47 AM

    Dear all;

    I have increased ztta/roll_extension = 2Gb and em/initial_size_MB = 4092 and the problem still exists.

    PRIV processes still happening but I would like very much to thank you for your help.

    Now I am not sure to insert the rdisp/wppriv_max_no and rdisp/max_priv_time parameters.

    Albe.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      You can change it to 720 kernel but if the issue is due to less memory you will still have it.

      So try to adjust the parameters and see how it goes.

      When this problem start was it after the upgrade of kernel or some new project went live.

      Below are the notes for the kernel upgrade to 720_EXT

      Note 1636252 - Installing a 7.20 kernel in SAP Web AS 7.00/7.01/7.10/7.11Note 1866499 - 7.20_EXT / 7.21_EXT Kernel - Only 64-bit support

      Thanks

      Rishi Abrol

  • avatar image
    Former Member
    Nov 12, 2013 at 11:04 AM
    Add comment
    10|10000 characters needed characters exceeded