Skip to Content
avatar image
Former Member

Crystal Reports 13.07 for visual studio 2012 not rendering in Browser

I am using a 64 bit machine,Windows 7,Visual studio 2012 ultimate, C# asp.net . I installed Crystal Reports 13.07 from this link SAP Crystal Reports, developer version for Microsoft Visual Studio: Updates & Runtime Downloadshttp://scn.sap.com/docs/DOC-7824 The above file installs the 64 bit runtime after the normal installation as it detects that I'm using a 64 bit machine.

Things go smooth until I run the application from the visual studio. It displays a blank page In chrome,firefox,instead of the report. I am attaching the Aspx page, aspx.cs page, Crystal reports page ,Web config page and the Browser page screenshots below. How do I overcome this problem?

AspxPage.jpg (89.4 kB)
Aspx-CS.jpg (98.7 kB)
CrystalReport.jpg (64.4 kB)
WebConfig.jpg (222.3 kB)
Browser.jpg (37.4 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Nov 06, 2013 at 03:49 PM

    Hello Ankur         

    Looking at the SAP Crystal Reports, developer version for Microsoft Visual Studio - Supported Platforms documentation, Firefox may make sense:

    Chrome should work.  What version of IIS are you using? Does the report display in IE? What version of Chrome are you using? What's the OS?

    - Ludek

    Senior Support Engineer AGS Product Support, Global Support Center Canada

    Follow us on Twitter

    Share Your Knowledge in SCN Topic Spaces


    Untitled.png (40.9 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Ludek ! I am running the application in my development machine(64 bit). I am not yet running the project in IIS

      Chrome Version 30.0.1599.101 m,Windows 7 (Ultimate),Visual Studio 2012 ultimate. Is my Web config file (in my question) okay ? For your info , I had previously installed 13.05 version prior to removing and installing the 13.07 version.

      .The report is not displaying in any browser . This is what I am getting the following error in IE9

      IE9.jpg (182.8 kB)
  • avatar image
    Former Member
    Nov 07, 2013 at 11:34 AM

    Hi

    Can you see data when you preview your report in application?

    One more thing, look at the CR version in register tag of aspx page which will be added as you drag and drop CR viewer in web page. compare this with what you've updated in your system.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      All the dlls in  my case are having having version 13.0.2000.0 . I can proceed to IIS only after running it successfully in visual studio. I tried in 3 different pcs in my office now and the result is no different . It displays a blank page.

  • avatar image
    Former Member
    Nov 07, 2013 at 03:00 PM

    I have found an answer to this question  i.e., WE MUST INSTALL/ACTIVATE  IIS . It seems crystal reports 13 does not yet run on the visual studio server /IIS express.

    Add comment
    10|10000 characters needed characters exceeded