Skip to Content
Former Member
Nov 05, 2013 at 10:31 AM

ASE ODBC 64 crashes on Windows 2012


Hi all,

When trying to configure a ASE x64 ODBC on a Windows 2012 R2 the application crashes as soon as I chose Adaptive Server Enterprise in Create New Data Source and click Finish. With the following error produced in the event log on the server.

CAIRO3-TEST 1000 Error Application Error Application 2013-11-04 15:29:41

Faulting application name: odbcad32.exe, version: 6.3.9600.16384, time stamp: 0x5215f2d8

Faulting module name: sybdrvodb64.dll, version:, time stamp: 0x51797dfa

Exception code: 0xc0000005

Fault offset: 0x0000000000034f2a

Faulting process id: 0x15d8

Faulting application start time: 0x01ced96a47f587ba

Faulting application path: C:\Windows\system32\odbcad32.exe

Faulting module path: C:\sybase\DataAccess64\ODBC\dll\sybdrvodb64.dll

Report Id: 8a6da0ad-455d-11e3-80be-005056a85df8

Faulting package full name:

Faulting package-relative application ID:

A couple of FYI…

The ASE ODBC installed is 15.7 SP103
I have tried installing the ASE ODBC on a Windows 2012 with the same result as on R2
ASE ODBC 32 seems to be working fine but seems not to be usable when connecting to the ASE witch is a x64 installed on a x 64 Solaris.

Any ideas?