Skip to Content

Messages stuck with green flag A. Status (XI 2.0)

Hi All,

we are running an instance of XI 2.0 and for this interface in particular we are pulling a file off an FTP server via the file adapter and pushing it through to a remotely enabled function which creates a batch session on our SAP R/3 4.6C instance. The interface used to work but we have now changed the name of the function within R/3 then made the corresponding changes in XI. Since we've done this the messages appear to be getting caught up somewhere between XI and R/3. The XI monitor (SXMB_MONI) shows in the A. Status field a green flag. To me this would imply that it is processing on the remote end (R/3) however there has not been any batch session created. This flag remains green indefinately.

I thought it could have something to do with XI caching some old objects so I ran tx SXI_CACHE and did a complete cache refresh (F6). This did not change anything. I have cleared all messages out of the queue using tx SM58. Then after reading another post in this forum I ran tx smq1 and smq2 to clear messages out of there but there was nothing in those queues.

When I push another message through it will sit in SXMB_MONI with the A.Status field having a green flag. Then I look in tx SM58 and find that the status text field displays "Transaction executing" for a very long time. Eventually it changes to "timout during allocate of registered program / CP" but the message is not going through. The only thing that has changed has been the name of the function in R/3.

any thoughts?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 07, 2005 at 07:45 PM

    Hi Larry,

    It seems your message is getting stuck in queue.Check transaction SMQ1.Is there any queue present.Delete the queue and process you message again.

    Thanks.

    Rekha.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 07, 2005 at 09:27 PM

    Hi Larry,

    Transaction SM58 shows in the column 'Target System' where the message is being sent to.

    In SM59 (RFC Destinations) you can test the connection to this system.

    If this connection test gives errors, then you should look into the cause of this problem.

    What's the name of the RFC destination??

    Regards,

    Mark

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Mark,

      under the 'Target System' column in transaction SM58 it says "AI_RFCADAPTER_JCOSERVER". When I test it out it seems to work fine ... no errors.

      When I looked at the trace labeled "Adapter_rfc.log" within the adapter engine it lists the following error.

      >>RfcAdapter> Tue Oct 11 07:46:12 CDT 2005>>

      > cannot load function template for Z_XI_INTERFACE_TEST1

      > exception occurred, detail:

      > com.sap.mw.jco.JCO$Exception: (104) RFC_ERROR_SYSTEM_FAILURE: CPIC-CALL: 'C

      > MRCV'

      I'm not sure why we get this error. The function template Z_XI_INTERFACE_TEST1 does exist and we were using it before. If I run the interface again this error will no longer appear. It almost seems like it will display only once a day.

      any other thoughts?

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.