Skip to Content

ASE 16.0 on RHE7 SySAM error for hostID

I am installing ASE 16.0 on Linux RHES7 , seeing error related to hostID in SySAM :

the hostID was resolved from OS entry for "

ifconfig en01 " in old OS RHE6 the entry

was :

ifconfig eth0

Is it SySAM getitng confused with the new OS version and can not solve hostID from OS to match the one from lic file ?

SySAM: Invalid host. The hostid of this system does not match the hostid specified in the license file. Unserved licenses can only be used on the host for which the license was generated. If the license is intended for use on this machine then you need to check-in the license and regenerate it using the host id for this machine.
kernel SySAM: The hostid of this system does not match the hostid

00:0000:00000:00000:2017/01/13 13:37:10.54 kernel SySAM: License hostid: xxxxxxxxxxxxxxx1
00:0000:00000:00000:2017/01/13 13:37:10.54 kernel SySAM: License search path: /opt/sybase/SYSAM-2_0/licenses/SYBASE_ASE_DE.lic:/opt/sybase/SYSAM-2_0/licenses/SYBASE_ASE_XE.lic:/opt/sybase/SYSAM-2_0/licenses/xxxxxxxxxxxxxxx
00:0000:00000:00000:2017/01/13 13:37:10.54 kernel SySAM: FlexNet Licensing error:-9,57

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Jan 13, 2017 at 11:35 PM

    Does the hostid you're using match with what's returned by SYSAM's lmutil lmhostid?

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 16, 2017 at 03:58 PM

    HI Mark,

    lmutil lmhostid returnns 0:00:00...

    the OS ifconfig eno1 file has a entry for ether : and here is the hostID value I used to generate the Sybase SySAM lic file

    Thank you

    Isabella

    Add comment
    10|10000 characters needed characters exceeded

    • lmutil lmhostid shows what SYSAM is expecting to see. If you're getting all zeros then it sounds like a potential issue with the SYSAM installation, a bug with SYSAM for this particular OS, or potentially a OS config issue.

      Do you have any other RHE7 hosts you could run tests on (eg, install SYSAM and see if lmutil lmhostid returns the same hostid you're expecting)?

      I'd recommend opening a case with tech support

  • Jan 18, 2017 at 08:30 PM

    update

    I managed to solve the hostID, RHES7 and ASE 16.0 error: I upgrade to ASE 16.0 EBF 26670 SMP ( this has the last version of lmutil ver 11.14)

    Add comment
    10|10000 characters needed characters exceeded