Skip to Content
0
Oct 31, 2013 at 02:14 PM

SAP UI5 toolkit and ABAP Team Provider for NW GW in Eclipse

304 Views

All.

I am having problems installing both the SAPUI5 toolkit and the ABAP Repository Team Provider plugin for Eclipse, to deploy UI5 projects to SAP NW Gateway.

The problem is also described in thread: http://scn.sap.com/thread/3426430

I have tried following the solution described by starting fresh, and installing the plugins in this order:

- GWPA plugins

- SAPUI5 ABAP Repository Team Provider

- SAPUI5 Application Development Toolkit

I have tried to install both the toolkit version 1.12.1 and 1.16.3 - neither works.

Please note that there is no problem installing EITHER the Team Provider OR the Toolkit.

But I cannot get both installed in the same Eclipse environment at the same time.

I am getting errors like:

Cannot complete the install because of a conflicting dependency.

Software being installed: SAPUI5 Application Development 1.12.1 (com.sap.ide.ui5.app.feature.external.feature.group 1.12.1)

Software currently installed: SAPUI5 ABAP Repository Team Provider (Developer Edition) 1.14.4 (com.sap.ide.ui5.team.feature.feature.group 1.14.4)

Only one of the following can be installed at once:

SAPUI5 Common 1.14.4 (com.sap.ide.ui5.common 1.14.4)

SAPUI5 Common 1.12.1 (com.sap.ide.ui5.common 1.12.1)

Cannot satisfy dependency:

From: SAPUI5 Application Development 1.12.1 (com.sap.ide.ui5.app.feature.external.feature.group 1.12.1)

To: com.sap.ide.ui5.common [1.12.1]

Cannot satisfy dependency:

From: SAPUI5 ABAP Repository Team Provider (Developer Edition) 1.14.4 (com.sap.ide.ui5.team.feature.feature.group 1.14.4)

To: com.sap.ide.ui5.common [1.14.4]

I hope someone can help.

Thank you and best regards,

Søren Hansen