Skip to Content
avatar image
Former Member

Error 2753. The File is not marked for installation.

Okay, I have just downloaded and tried to install the Crystal Reports for Visual Studio 2010 executable package 13_07.  And, like so many others, I have also received the infamous error "Error 2753. The File "agent.exe.6ED28686_7B19_420C_B255_5B6C1BD2C705" is not marked for installation."  I have read so many forums on how to get past this, but still no luck.  Here is what I have done thus far.

First, installing this on Windows 7 Professional and I have Visual Studio 2010 Ultimate

I have removed all Flexera software, there is nothing even related to Installshield on my computer.

I have uninstalled all prior attempts at the Crystal Reposts installations

I have removed the Crystal Reports folder in program files

I have cleared my cache

I have checked the registry for errors

I have rebooted my machine and ran the .exe installation with no other Windows programs open

This is all of the information I found on this and other forums, but I still have had no luck.  I have seen this error on forums from 3 years ago and find it hard to believe it is still not fixed.

I would appreciate any information.

Thank you in advance.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Oct 31, 2013 at 08:28 PM

    Hi Jerry,

    This is not a CR issue but an OS problem, nothing we can do to fix it. That error is reported by MSIExec, Google search found a few other cases.

    Look in your C:\Users\YourUserName\AppData\Local\Temp folder you will find an install log that CR generates and copies over if successful but gets removed if failed. Before you kill the message have a look in there it should tell you what the file is causing the problem. Then search the PC and the registry for the name.

    Also, don't use those "registry fix it" programs, I have never found one that ever works properly, they usually end up make some program un-usable.

    Possibly something is still left over from an uninstall.

    Check the “PendingFileRenameOperations” key under:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager

    If there is anything in there reboot first, if it's still there then just delete all text, not the key.

    And did you search for the kbase articles also?

    Does it happen on anyone elses PC or Image?

    Don

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thank you for the reply.  I will check into everything you mentioned and get back to you.

      At present, it is only happening on my machine as I am evaluating Crystal Reports, Telerik, and other report makers for a client.  The fact that Crystal conflicts with Windows 7 OS does scare me a bit as I have had no issues with others I have checked.  But, I will do all I can to give Crystal a fair shot.

      Thanks again