Skip to Content
0
Oct 28, 2013 at 10:12 PM

Transports fail to import after failing over database (TP, TMS)

45 Views

We're currently in the process of testing some systems installed on SQL Server 2012 using Availability Groups instead of Windows Clustering. We got everything up and running on the first SQL server instance and transports were importing with no trouble. We set up our second SQL instance in the availability group and we tried failing over for the first time today.

So far, the only issue that I've run into is that I can no longer import transports into the system. The import fails with "Transport control program tp ended with error code 0232" and "Errors: connect failed". If I pull up the output, I can see that TP is still trying to connect to the original SQL server instance and not the one that we've now failed over to. It's actually referencing the Physical Host name of the SQL server and not the DNS entry that I've setup as the DBHOST in the profiles and in the TP_DOMAIN_SID.PFL file.

I've tried resetting the host name buffers in SM51 and I've also tried restarting the app server to no avail. Does anyone happen to know anywhere else that the system might be saving off the physical host name of the SQL server that TMS (TP) would be using?