Skip to Content
author's profile photo Former Member
Former Member

Deployment of ear stops in NDS

Deployment Stuck in NDS

Posted: Oct 5, 2005 10:05 AM Reply E-mail this post

Hello Folks,

I have a J2EE Enterprise App Project in NDS. I am able to create ear file, deploy to my local J2EE engine. But the last time I deployed, the "Deploy Output View" stuck at the log "<b>Created a temporary copy: ....ear[more]</b>" and doesn't move. Something wrong with SDM?

But since, the deployment is stuck in NDS. I cannot right click on ear and say "Deploy to J2EE Engine" as its now shaded. So, I have to restart NDS and J

I tried restarting J2E engine but I still have the same problem, this time when I deploy, it fails with Deployment Aborted and details say

Deployment exception : Server localhost did not accept login request as apiadmin on port 50018 - Cannot log in. There are already active sessions:

Session id 0 / An administrator logged in via API /

Inner exception was :

Server Localhost did not accept login request as apiadmin on port 50018 - Cannot log in. There are already active sessions:

Session id 0 / An administrator logged in via API /

Any solutions? This is happening only for my Enterprise Application Projects only. WebDynPro project deployment is running fine.

Thanks and I appreciate ur time,

Kiran

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Oct 06, 2005 at 05:12 PM

    Have you ever worked the J2EE visual administrator from SAP? Under the Server-> services -> Deploy, you can do the same deployment as you would from NDS. You will already be logged into J2EEAdmin. This might give you a clearer idea of what the problem is.

    Have you ever been able to deploy a J2EE App? Did you change you app lately, possibly adding a bunch of new packages. I know that when I was programming pure J2EE stuff, it deployed very quickly. Then when I added JARs so that my JSPs could access additional functionality, it took quite a bit longer. I'm sure it depends on how big you EAR is.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Nathan,

      I wanted to add, when I try logging into Visual Admin or SDM, I cannot. I get an <b>There is an already Active session open...</b> for SDM and <b>...BaseSecurityException</b> for Visual Admin.

      So, the only option left is restart engine and NDS.

      Any other pointers?

      Thanks,

      Kiran

  • author's profile photo Former Member
    Former Member
    Posted on Oct 06, 2005 at 07:35 PM

    Yes, Restart you SDM and then try just using the Visual Admin for the deployment. Could the slowness have anything to do with your network? What version of the server and NDS are you using?

    I have been working on SP11 for the server and Version: 2.0.9 Build id: 200411030238 for a couple weeks and had no problems with it, other than a slight slowness when deploying an application with a lot of includes.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.