Skip to Content
author's profile photo
Former Member

Spool problem

Hi,

I am not getting complete output in the Spool.Below please find the code.

Thanks in advance,

Kishore

DATA: val(1) TYPE c,

lay TYPE pri_params-paart value 'X_65_1023',

lines TYPE pri_params-linct value '1023',

rows TYPE pri_params-linsz value '65'.

data: params LIKE pri_params.

CALL FUNCTION 'GET_PRINT_PARAMETERS'

EXPORTING

DESTINATION = 'LOCL'

LAYOUT = lay

LINE_COUNT = ROWS

LINE_SIZE = LINES

NO_DIALOG = 'X'

IMPORTING

OUT_PARAMETERS = params

VALID = val

EXCEPTIONS

ARCHIVE_INFO_NOT_FOUND = 1

INVALID_PRINT_PARAMS = 2

INVALID_ARCHIVE_PARAMS = 3

OTHERS = 4

.

IF SY-SUBRC <> 0.

MESSAGE ID SY-MSGID TYPE SY-MSGTY NUMBER SY-MSGNO

WITH SY-MSGV1 SY-MSGV2 SY-MSGV3 SY-MSGV4.

ENDIF.

new-page print on parameters st_params no dialog.

FORMAT COLOR COL_HEADING INTENSIFIED ON.

WRITE:/ TEXT-041.

FORMAT COLOR OFF.

SKIP 1.

FORMAT COLOR COL_GROUP INTENSIFIED ON.

WRITE:/ TEXT-021,07

TEXT-022,12

TEXT-023,23

TEXT-024,34

TEXT-025,48

TEXT-026,61

TEXT-027,75

TEXT-028,83

TEXT-029,92

TEXT-030,104

TEXT-031,116

TEXT-032,124

TEXT-033,136

TEXT-034,155

TEXT-035,171

TEXT-036,194

TEXT-038,210

TEXT-037.

FORMAT COLOR OFF.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Oct 06, 2005 at 11:40 AM

    Hi Kishor,

    Check whether the format 'X_65_1023' is defined for the printer you have selected. This could be the problem with the number of columns in the format. Try changing to the one which is available. You can try this by not giving the option 'NO DIALOG' with the command 'NEW-PAGE'.

    Cheers

    Vinod

    Add comment
    10|10000 characters needed characters exceeded