Skip to Content
0
Former Member
Oct 25, 2013 at 08:49 AM

Install Apache on AIX 7.1

447 Views

Hi,

I need install Content server on AIX 7.1 but i have problem with compiling Apache server. I have followed SAP note 1299254 - Content Server on AIX 6.1 but during command "./buildconf" we got error

autom4te: need GNU m4 1.4 or later: /usr/bin/m4

autoheader: '/opt/freeware/bin/autom4te' failed with exit status: 1

Creating configure ...

autom4te: need GNU m4 1.4 or later: /usr/bin/m4

I was able to repair it to rewrite path in the file /opt/freeware/bin/autom4te.

Didn't help when I tried to put /opt/freeware/bin before /usr/bin in the PATH variable.

Next step i performed like: "./configure –-prefix=/usr/.../apache"

In the other step "./make" I got error:

saptest:/oracle/tmp/apache/httpd-2.0.63# make

Making all in srclib

make[1]: Entering directory `/oracle/tmp/apache/httpd-2.0.63/srclib'

Making all in apr

make[2]: Entering directory `/oracle/tmp/apache/httpd-2.0.63/srclib/apr'

Making all in strings

make[3]: Entering directory `/oracle/tmp/apache/httpd-2.0.63/srclib/apr/strings'

make[4]: Entering directory `/oracle/tmp/apache/httpd-2.0.63/srclib/apr/strings'

/bin/sh /oracle/tmp/apache/httpd-2.0.63/srclib/apr/libtool --silent --mode=compile gcc -O2 -maix64 -DHAVE_CONFIG_H -U__STR__ -D_THREAD_SAFE -I../include -I../include/arch/unix -c apr_cpystrn.c && touch apr_cpystrn.lo

In file included from /opt/freeware/lib/gcc-lib/powerpc-ibm-aix5.2.0.0/3.3.2/include/ctype.h:143,

from ../include/apr_lib.h:32,

from apr_cpystrn.c:20:

/usr/include/sys/localedef.h:577: error: parse error before "cur_locale"

make[4]: *** [apr_cpystrn.lo] Error 1

make[4]: Leaving directory `/oracle/tmp/apache/httpd-2.0.63/srclib/apr/strings'

make[3]: *** [all-recursive] Error 1

make[3]: Leaving directory `/oracle/tmp/apache/httpd-2.0.63/srclib/apr/strings'

make[2]: *** [all-recursive] Error 1

make[2]: Leaving directory `/oracle/tmp/apache/httpd-2.0.63/srclib/apr'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/oracle/tmp/apache/httpd-2.0.63/srclib'

make: *** [all-recursive] Error 1

I tried also newest version of httpd and autoconf but result was same.

Regards,

Martin