Skip to Content

F4 Amodal sort error in SAPGUI 7.30

Hello all,

We've come across a new error in the 7.30 SAPGUI that is not fixed in Patch 6 Hotfix 1. If you use the standard, out-of-the-box mode for F4 search helps, certain fields cannot be sorted in the F4 'hit list'. As an example, choosing the 'Organizational Unit' field from an infoset in SAP Query as a selection field, you cannot sort the list of org units by name, nor even start or stop dates for org units. Session tracing reveals a "bad index" error in program SAPTABControl.1, module WDTTab Control, method refreshResultTable. It looks like sapwdtaocx.ocx is the offending component.

There is a workaround, which is to switch F4 mode to Modal (Dialog). However, we'd prefer to use the Amodal default.

The error is new in 7.30. It didn't occur in SAPGUI 7.20.

I've logged a Customer Message about it, but I'm wondering if anyone else has encountered this error?

Best regards,

Matt

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    Posted on Jan 08, 2014 at 01:38 PM

    Just confirming that the problem is fixed in Patch 7 again.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 08, 2014 at 02:00 PM

    Hello Matt,

    Did you try patch 7 yet?

    If yes, then mark the question as answered for the benefit of other users.

    If not ,then we also need F4 and Gridview traces from the GUI.


    This can be captured from ALT+F12 => Options => Traces =>Session Traces

    Check F4 Help

    &

    Gridview Control

    Kindly upload the traces to the message.

    Regards,

    Jude


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 14, 2013 at 08:37 AM

    Hi Matt,

    discovered the same problem with 7.30 Patch Level 6 here.

    Quite sure it worked before (with PL 5).
    Hopefully SAP will correct it with PL7 in a few weeks.
    And thanks for mentioning the workaround - nice to know.

    Best regards,

    Harald

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Harald,

      SAP has responded to the Customer Message and they are working on it now. They were not previously aware of the problem. I didn't verify if the problem existed on Patch 5 or not; if it's true the problem is new with Patch 6, that may be useful for SAP to know, so I passed that on to them.

      Best regards,

      Matt

  • Posted on Oct 22, 2013 at 02:40 PM

    The fix is in the works now, and will be released in Patch 7, referenced by Note 1925920 (not yet released).

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.