Skip to Content

SAP HANA Express Edition WebIDE XS aps not started

Hello,

I downloaded SAP HANA 2.0 Express Edition VM with Server and Apps option

I could run the HANA by following the guide http://www.sap.com/developer/tutorials/hxe-ua-getting-started-vm.html

But when I run

xs apps

to see the status of XSA applications, I see many of the aplications are in not started status

For example

webide 0/1 started so as I understand the WebIDE is not started

And also the cockpit-admin-web-app is not started it is 0/1 status where 1/1 started was expected

The guide assumes those xs apps to be started but does not provide any solution if they are not in the correct status.

How can I start webide and cockpit-admin-web-app and others?

Sorry, I could not find a community for HANA Express!

21.png (50.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Jan 13, 2017 at 10:37 AM

    How long did you wait to check the app status? Starting of the instances takes quite a time (depending on your machine). So it can be that the status is already "STARTED" and 0 instances are displayed. For instance on my NUC with a Core I5 and 32 GB of RAM it takes ~10 minutes until the instances for the XS apps like Web-IDE are started.

    Starting/Re-starting of apps can be done e.g. by the xs start/xs restart command or since 2.0 via the application management app in the admin cockpit (if the instance for that app is running :-)).

    Regards,
    Florian

    Add comment
    10|10000 characters needed characters exceeded

    • Thanks Eralper & Florian

      I had exactly the same issue and it will be 30+ minutes on my i5 laptop with 16GB. Can I suggest the "Getting Started" document be updated please?

      Can these the status of these apps be seen via HANA Studio?

      It would be good to point out in the guide that the user can connect to the hxehost at this stage from Studio also, and how to do it. The whole HANA Studio section with use of port 90 in adding the system to HANA Studio is not covered - I guess you are trying to move to web admin tools, but HANA Studio is still widely used.

      Andy

  • avatar image
    Former Member
    Feb 01, 2017 at 09:24 PM

    Thanks Eralper and Andrew for your comments. We on the HANA express and XSA teams are looking at different ways to reduce the time it takes for apps to start up and to reduce the memory they consume. Also, I will also let our documentation team know about the need to provide some pointers on handling this issue.

    Add comment
    10|10000 characters needed characters exceeded

    • I'd have to pile onto this and say XSA really bogs things down on the otherwise quite low footprint and snappy HXE 2.0... Anything to speed it up and reduce memory footprint would be great. I can get away with running HXE server-only on a MacBook Pro 2016 using 12GB VM, however the limit on MacBooks is 16GB so without resorting to a cloud host or a homelab, it makes playing with HXE+XSA while travelling difficult :(

  • Oct 19, 2017 at 10:54 AM

    Bonjour, j'ai eu le problème avec mon VM. Je pense que une bonne documentation dans ce sens nous sera vraiment utile.

    Add comment
    10|10000 characters needed characters exceeded

    • Salut Annie,

      Merci de ce guide cela nous aide beaucoup. Au fait, la mémoire RAM alloué à mon VM était trop petite. Après avoir augmenté la RAM, la VM a démarré correctement sans prendre trop de temps.

      Merci.

      -Serigne

  • Aug 15 at 09:26 PM

    We are on HANA Express 2.0 SP 2 provisioned through cal.sap.com and it takes forever for the webIDE to start. Did you find a way to address this issue?

    Thanks,

    Jay

    Add comment
    10|10000 characters needed characters exceeded