Skip to Content
author's profile photo
Former Member

Detailed Navigation doesn't change on navigation

Hi,

I have an iView that contains links to other pages in the portal, and when I click the link, the correct page launches, but the detailed navigation is still highlighting the location from where the link was launched from.

I am using the EPCM.doNavigate going to an iView, EPCM.doNavigate('ROLES://portal_content/.../iViewName'), and a page, EPCM.doNavigate('ROLES://portal_content/.../pageName')

Is there something else that needs to be set in the doNavigate that controls the detailed navigation?

Oh yeah, we are running EP6 SP12.

Cheers,

Kevin

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    author's profile photo
    Former Member
    Oct 02, 2005 at 08:28 PM

    hi Kevin,

    you should use the follow link to open an iview and mark the navigation panel:

    a href="/irj/portal?NavigationTarget=ROLES://portal_content/YourRoleID/YourWorksetID/YourPageID/YouriViewID" target="_top">

    you can stop the link string at a page or an iView a page is a better option

    Hope it helps,

    Yoav

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Yoav,

      Thanks for the help. I found what the problem was. I had to go into the role and then take the property of the pages that I wanted. Once I plugged that in, it works like a dream.

      This will make people happy.

      Cheers,

      Kevin

  • author's profile photo
    Former Member
    Oct 02, 2005 at 08:34 PM

    Hi Kevin,

    Using the EPCM.doNavigate() , specifing the page path is the correct way. The behavior you have discribed might occur if your target page is not located under an entry point, or if it's marked as "invisible in navigation iViews". Can your target page be accessed diretly/manually (using the navigation iViews) ?

    Eitan.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Eitan,

      I don't have my page marked as 'invisible in navigation iViews'. Yes, the target page I'm trying to access from my iView is in the detailed navigation. I don't believe that it is set up as an entry point (iView or Page). Upon checking, it is not an entry point and it is not a default entry point.

      Cheers,

      Kevin