Skip to Content
0
Former Member
Oct 04, 2013 at 05:07 PM

UI5 SP5 Launch Page Error

366 Views

Hello,

We have the following system configuration:

Windows 2008

MS SQL 2008

ECC 6.0 EhP6

SAP NetWeaver Gateway 2.0 SP7

UI add-on SP5

When GW was SP06 and UI add-on was SP4, I was able to configure the UI5 launch page to start successfully. Tiles for SAP Fiori applications would appear for our demo user based on the PFCG roles assigned. However, once GW was patched to SP7 and UI add-on to SP5, we see the following error in the Chrome developer trace when we go to the launch page:

Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://clklabvm29.lab.clockwork.ca:50000/sap/opu/odata/UI2/PAGE_BUILDER_PERS/Pages('%2FUI2%2FLAUNCH_PAGE')?$expand=allCatalogs/Chips

  1. 2013-10-04 12:09:42 Error in OData response for GET "/sap/opu/odata/UI2/PAGE_BUILDER_PERS/Pages('%2FUI2%2FLAUNCH_PAGE')?$expand=allCatalogs/Chips": HTTP request failed Details: In the context of Data Services an unknown internal server error occured - {"requestUri":"/sap/opu/odata/UI2/PAGE_BUILDER_PERS/Pages('%2FUI2%2FLAUNCH_PAGE')?$expand=allCatalogs/Chips","statusCode":500,"statusText":"Internal Server Error","headers":[],"body":"{\"error\":{\"code\":\"005056A509B11ED1B9BF9F46AA8E82ED\",\"message\":{\"lang\":\"en\",\"value\":\"In the context of Data Services an unknown internal server error occured\"}}}"} sap.ui2.launchpage.PageBuildingService sap-ui-core.js:41
  2. 2013-10-04 12:09:42 Error occured: Error in OData response for GET "/sap/opu/odata/UI2/PAGE_BUILDER_PERS/Pages('%2FUI2%2FLAUNCH_PAGE')?$expand=allCatalogs/Chips": HTTP request failed Details: In the context of Data Services an unknown internal server error occured - sap.ui2.launchpage.Home.controller sap-ui-core.js:41

In /IWFND/ERROR_LOG, we see the following error:


..ERROR_INFO The system tried to insert a data record, even though a data record with the same primary key already exists

In the application log for this error, we see the following:

@5C\QError@ 2 Exception of type CX_SY_OPEN_SQL_DB has occurred. See details for more information @16\QDetail exists@

/IWFND/CM_LOGGING006 @5C\QError@ 3 Exception of type CX_SY_NO_HANDLER has occurred. See details for more information @16\QDetail exists@

/IWFND/CM_LOGGING006 @5C\QError@ 4 Exception of type /IWCOR/CX_DS_INTERNAL_ERROR has occurred. See details for more information @16\QDetail exists@

/IWFND/CM_LOGGING006

In the details for the CX_SY_OPEN_SQL_DB error, the entry says "The system tried to insert a data record, even though a data record with the same primary key already exists."

We have asked one of our developers to look into the code to find where the error occurs. Does anyone have any advice on where to find the program where the exception is thrown?

I've checked in SCN and SAP notes using the term UI add-on and CX_SY_OPEN_SQL_DB but have not found anything.

I've also gone through the blog post by Masayuki Sekihara (http://scn.sap.com/community/mobile/blog/2013/07/08/sap-fiori-ll07--common-mistake-for-launch-page-setting) and aside from applying SAP Note 1899518, the other notes could not be implemented.

One thing we can try is to restart the Gateway and ICF services. If that doesn't work, does anyone have any other troubleshooting suggestions?