Skip to Content

CTS+ Import Issue Deploy proxy server not running or Web service not installed

Hi Experts,

I am working on CTS+ to Transport Non-ABAP objects.

My non-ABAP Source & Target Systems are Netweaver EP 7.01

The Transport System is Solution Manager 7.1 i.e. Netweaver 7.02

I have done all the required configuration, while doing my first transport (Loose Coupling) I am not able to import the transport on Target.

Details:

1) I have created a Transport Request in Transport Organizer Web UI of Solution Manager, with Source as Portal DEV & Target Portal PRD

2) I attached a .ear object to that request and released the request

3) After releasing, I was able to see the request in the Queue of Target System in STMS (Solution Manager)

4) When I began to import the TR in Target, it got terminated with RC=12 and message "Deploy proxy server not running or Web service not installed"

I performed few checks, to get through the issue:-

1) SDM is up and running

2) Port 5xx18 is open from Solution Manager to Target System for Deploying via SDM

3) SDM User/Password is maintained correctly, user is SDM

4) DeployProxy web service is available in Solution Manager Java

5) Logical Port CTSDEPLOY is active in Solution Manager 000 and path set to '/DeployProxy/default?style=document'

6) HTTP Connection CTSDEPLOY is created from SOLMAN-ABAP to SOLMAN-JAVA & Connection test is OK (200)

I am not sure, what is the issue. Is DeployProxy Service need to be checked at target also?

I have already checked up everything from notes,SCN, Web can't find anything related.

Your help is highly appreciated.

Regards,

Akshay

SCN.JPG (121.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Oct 01, 2013 at 06:19 AM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Dec 17, 2013 at 11:17 AM

    I understand that Akshay problem was solved after changing the RFC CTSDEPLOY Technical Setting's and use the FQDN Correctly and Service no to 8000.


    Even I have changed mine from 50000 to 8000 and tried to import the transport. but no success.


    Any clue?

    Add comment
    10|10000 characters needed characters exceeded

    • Can you please re-check the HTTP port in SMICM?

      It's 8000 and active?

      The port in RFC should be HTTP Port (8000 or likewise) as compared to suggested 5<xx>00 port.

      Otherwise, consider opening an OSS, this at time I was configuring seemed real buggy.

      Regards,

      Akshay

  • avatar image
    Former Member
    Mar 10, 2015 at 06:40 AM

    Hi Akshay,

    We are also facing the same issue as you were facing.

    We have configured the service in development successfully. Now we are facing issue while configuring it to the quality system.

    Please let me know how you have overcome this issue.

    Regards,

    Saket

    Add comment
    10|10000 characters needed characters exceeded