Skip to Content
0
Former Member
Oct 01, 2013 at 03:14 AM

Will JDK 1.6 work for NWDS PI 7.11 or JDK 1.5 is must?

60 Views

All,

I have installed NWDS for PI 7.11 and Java JDK 1.6.

As I understand we need Java 1.5 for NWDS so as to generate java client proxies for dir API using 'SAP Netweaver' as WebService Runtime.

I see that when a new project is created we have teh option to chose the java complier which was by deafult 6.0, but I changed it to 5.0. With 6.0 the system does nto allow me to use 'SAP Netweaver' as WebService Runtime.

This works fine and I am able to create the Java Proxy clients successfully.

However the in Package Explorer I see the JRE SYSTEM LIBRARY as JAVASE 1.6.

I do not have to change the default JRE as I have only java 1.6 installed on my system.

Do you think this will cause a issue?

Attachments

Capture1.JPG (127.3 kB)
Capture2.JPG (137.5 kB)
Capture3.JPG (76.9 kB)