Skip to Content
0
Former Member
Sep 30, 2013 at 01:44 PM

CPS - SAP System connection failing sporadically

100 Views

Hi all,

Has anyone seen similar to this?

A SAP system connection that

a) in the SAP system definition is AOK - system connect string and XBP connection both test AOK

b) BUT the Process Server will be unreliable - one of three things is likely to happen at startup

i - starts up AOK

ii -- starting up very slowly

iii- fails to startup at all

Security traces reveal nothing, It seems to be something else.


There are no useful Op Messages in CPS.

In the NetWeaver AS Java server node logs we see something like this recurring - we are not certain if it is directly linked:

#2.#2013 09 30 12:44:08:622#+00#Warning#com.sap.engine.core.thread.ShmThreadLoggerImpl#
#BC-JAS-COR#kernel.sda#C0008F166847374F00000000000037BE##redwood.com/scheduler-ear#com.sap.engine.core.thread.ShmThreadLoggerImpl#deploy_service#0##6D7C74DA212C11E3A2B400000168884A##6d7c74da212c11e3a2b400000168884a#0#Thread[Redwood monitoring for SAP instance SS_<SID>.<SID> worker 1,5,Redwood monitoring for SAP instance SS_<SID>.<SID> workers]#Plain##
The predefined size of the shared memory monitoring slots for the thread system is reached: size[600], used[600], type[thread table]. Every thread started from now on will be fully functional but will not be visible in the MMC thread monitoring. You need to reconfigure the shared memory monitoring slots for threads.#


We're still testing to see if there are other logged symptoms that directly relate but so far this is inconclusive.