Skip to Content
author's profile photo
Former Member

File Adapter using NFS: File Path

Hi All,

I'm using a file adapter with NFS. My destination folder is a shared folder on a network computer. How do i specify the path.

example: Machine IP: 123.44.55.33 Shared Folder: Sandeep

What should i specify in the Target Directory field.

Thanks,

Sandeep

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Sep 30, 2005 at 08:48 AM

    hi Sandeep,

    if you're using nfs than you folder has to be accessible

    from the XI server

    (as a folder)

    you cannot give path to a folder on a another machine

    just showing the path (ip etc.)

    the only way to do it is to map a folder on your XI

    server to another server (shared one, etc.)

    this way in file adapter parameters you can only give the

    path to an XI server folder but the file will be places somewhere else 😊

    Regards,

    michal

    Message was edited by: Michal Krawczyk

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 30, 2005 at 09:07 AM

    Hi Sandeep,

    If your XI server and destination folder is in same network

    you can give path like <b>//ip/folder</b> ie. <b>//123.44.55.33/Sandeep</b>

    Hope this helps,

    Regards,

    Ananth

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Michal Krawczyk

      Hi Michal,

      I have tried it by giving the network path of the shared folder on the XI server. It works. The format is


      serverName\Folder\

      Thanks,

      Sandeep

  • author's profile photo
    Former Member
    Sep 30, 2005 at 11:49 AM

    Hi Sandeep,

    Instead of using NFS you should use File Tranfer Protocol.

    In FTP connection parameters:

    Server : Your system ip address

    port : 21

    username: Give a local user name on your machine

    Folder : You should place your folder in place accessible by ftp server. Normally for office2000 operating system it should be in ftproot folder.Ofcourse u can specify what should be your ftp default folder also.

    Before doing this u should check whether ftp service is running on your system or not. If not running then goto add/removeprograms and in that select add/remove windows components. and select Internet Information Services and click on details there select ftp service and run it.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Gowtham,

      I am using FTP for my File interface. I connect to XI using VPN, I configured my local system with FTP server and gave the IP and login authentication in the Adapter settings. Still the adapter doesnt poll and read the file.

      Can you help me?

      Thilothama