Skip to Content
author's profile photo Former Member
Former Member

Shipment History Qty Mismatch in APO-BI Infocube with respect to Planning Book

Hi Gurus,

I currently ran into a problem, which is Shipment History Qty Mismatch in APO-BI Info cube with respect to Planning Book. As per my analysis i have checked the shipment history for a particular material for a posting period in ECC and then checked in APO-BI info cube here the qty is same, but when the data is loaded from info cube to planning area in shipment key figure the qty is being mismatched. We have a background job for loading the data from BI info cube to planning area, i have checked the variant for TSCUBE transaction here "add data" is unchecked.

Any help in this would be appreciated.!

Kind Regards

Kartik

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    Posted on Oct 03, 2013 at 07:42 AM
    1. Try Running Consistency Checks ,
    2. Check if your CVCs are correct .
    3. Also try to load only the single key figure for which you have trouble in TSCUBE.
    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 04, 2013 at 04:10 PM

    Hi Kartik,


    As mentioned by Ashfaq Ali

    Couple of things to check. Sorry if I'm stating obvious things.

    1. Did You chack your variant to make sure you aren't inadvertently filtering out any records from your cube prior to the trasnfer?

    2. Narrow down your discrepancy and Double check that the CVC exists for the data you are trying to load from the cube.

    3. You didnt specify whether the discrepancy was additional or missing data, but TSCUBE will only create (or update) data based on what is selected from the cube. So if you have some data for a different CVC already in the cube, that is not going to get wiped out?


    Regards


    Adam

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Adam,

      1. Did You chack your variant to make sure you aren't inadvertently filtering out any records from your cube prior to the trasnfer?


      I did a check on variant and it seems to be okay, and it should work properly. Yes we are filtering out values in info cube based on specific movement types and that is matching with the data in ECC system.

      2. Narrow down your discrepancy and Double check that the CVC exists for the data you are trying to load from the cube.

      yes i have checked this also and CVC do exist for this material.

      3. You didnt specify whether the discrepancy was additional or missing data, but TSCUBE will only create (or update) data based on what is selected from the cube. So if you have some data for a different CVC already in the cube, that is not going to get wiped out?

      I'm seeing both types Discrepancy's viz; missing of data(shipment qty) & additional data (shipment qty). It is very strange as for some parts this is working perfect but for other parts it is showing abrupt behavior.

      Kind Regards

      Kartik



  • Posted on Oct 05, 2013 at 01:57 AM

    Hi Kartik, there could be many possibilities that causes the issue, most porbably the disaggregation, both time-based and strucutral. Maybe you'll need to clarify first whether you're loading data into a DP planning area or SNP planning area. And if possible, please also attach the data you see in LISTCUBE, /sapapo/tscube settings (to every details) and the data you see in planning book.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 11, 2013 at 02:43 PM

    did u also check you selection and grouping conditions in /SAPAPO/TSCUBE

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Ashfaq,

      I have checked all but couldn't found anything that leads me to the root cause of this problem. Now i am thinking of creating a 2 step macro which would first copies 0 to the key figure shipment history in the planning horizon and then it would copy the data from infocube to planning area. I'm just curious would it work?

      Regards

      Kartik Rohilla

  • author's profile photo Former Member
    Former Member
    Posted on Dec 15, 2014 at 10:37 AM

    Dear Sap gurus,

    I'm still stuck here can't find seems to find out the root cause of this issue. Any help / suggestions would really be appreciated.

    Kind Regards

    Kartik

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Karthik,

      For all loaded key figures, it is advisable to reset and then load. To reset you can have a small macro "Row Shipment History" = Initial and then run the TSCUBE. Also you can check the Characteristic assignment whether the Date characteristic is the same in source and target. If it is not same, then check the TBP, probably Weekly data is being loaded to Monthly buckets.

      Also, when I see your screenshots, I see the Keyfigure assignment is happening between two different key figures. Are you checking the same KF?

      As everyone else had suggested, if all the above are not working then it could be an issue with Time Based Disaggregation and the Calendar (FYV and Posting periods).

      Regards

      JB

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.