Skip to Content

Insufficient previlege in data preview of database view

Hi All,

I'm facing error this error on data preview of database view.

SAP DBTech JDBC: [258]: insufficient privilege: Not authorized: line 1 col 25 (at pos 24)

I've all the privileges on the schema in which view has been created. Owner(creator) of the view is other user. Should I have privileges on that views also explicitly for data preview?

Regards,
Chandu.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Sep 27, 2013 at 10:25 AM

    Hi Chandu,

    This is already addressed by Lars in this thread.

    Regards

    Raj

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 27, 2013 at 10:17 AM

    Hi Chandu,

    For any database view:

    Not only privileges on the schema in which view has been created, but make sure you have select privileges on the schema from where you are getting the tables.

    For any HANA view(attribute/analytical/calculation) please check:

    1. Have you given select object privilege on your schema to _SYS_REPO user?

    If not execute with your user:

    grant select on schema <schema_name> to _SYS_REPO with GRANT option

    This helps in activation and data preview of the HANA views.

    2. Can you check does your user has at least one analytical privilege or not.

    Analytical privileges are created on HANA views in order to restrict the view of data for a user. You need to have atleast one privilege on your view to see the data.

    If you want to see all the data, ask your system admin to give to _SYS_BI_CP_ALL privilege.

    I sense your issue to be resolved with _sys_repo privilege.

    HAPPY HANA 😊

    Deepak Chodha.

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Deepak,

      Thanks for the quick reply. As I mentioned, its a database view, created at schema level. Not an information view ( attribute/analytical/calc view) at package level.

      View has been created in the same schema in which base tables reside. Data preview works on tables but not on these views. I've all privileges on that schema.

      There are no analytical privileges defined, I even tried with giving _SYS_BI_CP_ALL to my user, still doesn't work.

      The same issue is for other users as well. Data preview works only for the user who created the view, but not for others.

      Any other thoughts?? 😕

      Regards,
      Chandu.

  • Posted on Sep 27, 2013 at 06:11 PM

    Chandra,

    Your issue is really strange! Are you in the AWS cloud or is this your client instance? Which version of HANA revision are you running in the backend and frontend on? Both rev.#'s should match backend and front-end.

    Few months ago, I experienced a similar weird issue in my AWS cloud when I was in rev. 52. I full stopped the HANA server and started it and reassigned the grants and it fixed the problem. If you are in the cloud try this assuming my solution may work for you.

    Good luck!

    Rama

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.