Skip to Content
author's profile photo Former Member
Former Member

NWDS 2.0.13 Startup Problem

Hello. I run WIndows XP and I have installed J2EE 1.4 SDK

Then I have installed the NWDS 2.0.13

WHen trying to start the Developer Studio I get the following message :

Problem during startup. Check the ".log" file in the ".metadata" directory of your workspace.

In the log file I find the following information, but I do not know what to do with it.

I read in another post that I could try to run in console mode (java.exe instead of javaw.exe) to read extra infos on the console, but it disappears as soon as it appears...

Any help is welcome,

Claudio

!SESSION sept. 29, 2005 17:05:14.144 -


java.version=1.5.0_02

java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=fr_BE

Command-line arguments: -os win32 -ws win32 -arch x86 -feature com.sap.java.ide C:\Sun\AppServer\jdk\bin\java.exe

-Xmx512m

-Xms128m

-XX:PermSize=32m

-XX:MaxPermSize=128m

-DallUserDir='C:\Documents and Settings\All Users\Application Data'

-cp C:\Program Files\SAP\JDT\eclipse\SapStartup.jar com.sap.ide.eclipse.startup.Main

-os win32

-ws win32

-arch x86

-feature com.sap.java.ide

-showsplash C:\Program Files\SAP\JDT\eclipse\SapIde.exe -showsplash 600 -data C:\Documents and Settings\CiardeC\Documents\SAP\workspace -install file:C:/Program Files/SAP/JDT/eclipse/

!ENTRY Startup 1 0 sept. 29, 2005 17:05:14.144

!MESSAGE Sap NetWeaver Developer Studio - Build: 200507190119

!SESSION -


!ENTRY org.eclipse.core.launcher 4 0 sept. 29, 2005 17:05:19.883

!MESSAGE Exception launching the Eclipse Platform:

!STACK

java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:585)

at com.sap.ide.eclipse.startup.Main.basicRun(Main.java:286)

at com.sap.ide.eclipse.startup.Main.run(Main.java:795)

at com.sap.ide.eclipse.startup.Main.main(Main.java:602)

Caused by: java.lang.reflect.InvocationTargetException

at org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:861)

at org.eclipse.core.boot.BootLoader.run(BootLoader.java:461)

... 7 more

Caused by: java.lang.NumberFormatException: For input string: ""

at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)

at java.lang.Integer.parseInt(Integer.java:468)

at java.lang.Integer.parseInt(Integer.java:497)

at com.tssap.config.ProxySettings.parse(ProxySettings.java:184)

at com.tssap.config.ProxySettings.loadFromPreferences(ProxySettings.java:114)

at com.tssap.config.Startup.runBeforeWBStartup(Startup.java:39)

at com.tssap.util.startup.WBLauncher.run(WBLauncher.java:65)

at org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:858)

... 8 more

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 30, 2005 at 04:16 AM

    Hi Claudio,

    While installing NWDS you were asked for Proxy settings. Andf i guess you have not specified anything there. Because of that it gives such error.

    Regards,

    Bhavik

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Great it worked! In the above mentionned file the two following lines were already present:

      com.tssap.config/proxy=

      com.tssap.config/http.nonProxyHosts=

      Both with nothing after the = sign.

      I replaced the first with a fake proxy address as below

      com.tssap.config/proxy=10.212.1.111:80

      And the NWDS 2.0.13 finally started !

      The first thing I did after that was to go to menu

      WIndow / Preferences / Workbench / Proxy Settings

      and unchecked the "Use Proxy Server" checkbox.

      Claudio

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.