Skip to Content
author's profile photo Former Member
Former Member

Purchase order - problem with components upload

Hello experts,

I'm trying to create subcontracting purchase order with components. I'm using IDOC PORDCR1 Basic type PORDCR103.

I have not received any warning or error but components have not been created - I have only PO with 1 item without components.

According to note 197958 it should possible to create components using BAPI_PO_CREATE1, even if there is no BOM for used material - BAPI should create completely new BOM's.

Did somebody try to upload components for PO using this IDOC?

I would be grateful for any hint/help.

Best regards,

Wojciech Neska

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Sep 25, 2013 at 10:37 PM

    Have you searched for other OSS notes?

    I just did with this search string: BAPI_PO_CREATE1 subcontract components

    and got 28 hits.

    if you are working in a A&D system, then Note 968293 - Docu BAPI handling for subcontracting in A&D maybe relevant for you,

    if you are in a certain release in the core system, then maybe this one.

    Note 1100337 - BAPI_PO_CREATE1: Components are not transferred

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.