Skip to Content
0
Former Member
Sep 19, 2013 at 07:05 PM

An error occured at session creation

182 Views

Hi everyone :

I have a very strange issue in Webi Rich Client. (this uses to work before when we went live).

When I login to BI launch pad setting my pref to Rich client and open a new report using 3 tier mode. I get the following Error.

-----------------

com.sap.webi.client.toolkit.exception.WIException: ClusterFacadeImpl::openSession : java.lang.ArrayStoreException [repo_bridge - BridgeSessionFacade::getCustomMappedAttributes]

at com.sap.webi.client.toolkit.exception.WIExceptionFactory.create(WIExceptionFactory.java:18)

at com.sap.webi.client.toolkit.internal.WebIEngineRCImpl.processRequest(WebIEngineRCImpl.java:66)

at com.sap.webi.client.toolkit.internal.usersession.UserSessionRCImpl.logonWithSerializedSession(UserSessionRCImpl.java:130)

at com.sap.webi.client.toolkit.SessionContext.logonWithSerializedSession(SessionContext.java:92)

at com.sap.webi.ui.context.managers.SessionsManager.loginAndGetSessionContext(SessionsManager.java:319)

at com.sap.webi.ui.context.managers.SessionsManager.logOnRepository(SessionsManager.java:222)

at com.sap.webi.ui.context.managers.SessionsManager.initFirstSession(SessionsManager.java:138)

at com.sap.webi.ui.RichClientMain$InitWorker.doInBackground(RichClientMain.java:507)

at com.sap.webi.ui.RichClientMain$InitWorker.doInBackground(RichClientMain.java:463)

at javax.swing.SwingWorker$1.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)

at java.util.concurrent.FutureTask.run(Unknown Source)

at javax.swing.SwingWorker.run(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Caused by: com.businessobjects.common.CdzClusterMgmt.ClusterFacadeException: IDL:CdzClusterMgmt/ClusterFacadeException:1.0

at com.businessobjects.common.CdzClusterMgmt.ClusterFacadeExceptionHelper.read(Unknown Source)

at com.crystaldecisions.enterprise.ocaframework.idl.OCA.OCAcdz.WICDZServer._WICDZUserSessionStub.cloneSession(_WICDZUserSessionStub.java:183)

at com.businessobjects.rebean.wi.newserver.exec.WebiUserSessionExecutor.cloneSession(WebiUserSessionExecutor.java:30)

at com.businessobjects.sdk.core.server.internal.session.CloneSessionCommand.execute(CloneSessionCommand.java:56)

at com.businessobjects.sdk.core.server.internal.corba.CorbaServerImpl.doProcess(CorbaServerImpl.java:79)

at com.businessobjects.sdk.core.server.internal.AbstractServer.processIt(AbstractServer.java:171)

at com.businessobjects.sdk.core.server.internal.AbstractServer.process(AbstractServer.java:133)

at com.sap.webi.client.toolkit.internal.WebIEngineRCImpl.processRequest(WebIEngineRCImpl.java:63)

... 14 more

------------

== TECHNICAL DETAILS ===

BO Version: 4.0 SP05 Patch7

Client Os: Windows 7

Server OS: Windows 2008

Clustered environment with 2 nodes.

Application Server: Tomcat 6 (default)

We did the following checks - BUT NO LUCK 😔


• Nothing has changed @ the config stand point and we are on the same patch and Pack level across all the Env.

• Tried reproducing the same issue in another ENV and could not - other env works except PROD

• We checked to see if anything is blocking on the PORT in the server -everything is open

• We checked the same in the DNS and the F5 – same everything is open no blocks

• disabled the current Connection server (both 64 - 32) and re created new Connection server(s)

• Disabled default WPS and recreated new WPS - no luck

• Repair the client install (not required but tried that too) did not help either.

• Compared all the required JAR’s and everything seems to be fine on both the servers

• Passed the Host IP and the port directly to the CMS and the I/O Server – no luck.

• Checked the cluster properties files and could not trace any issue

• Stopped the tomcat and clean the localhost and restated the Tomcat server - 😔

• used individual tomcat host name to login to BI lanchpad - Same error as above

• Even opened an ticket with SAP on the same and they could not even find the root cause for this issue ( more then 10 day)

I have also attached the fiddler error log to it with both working and non-working env and the webi client log as well

any help from anybody will be greatly appreciated .

Thanks a lot this issue has almost killed an entire week

Thanks in advance

Balaji Karunakaran

FYI - the Fiddler files are

Non-Working Env.saz - changed the extn to txt

Working Env.saz - changed the exten to txt