Skip to Content
author's profile photo Former Member
Former Member

Fiscal week values not getting in sorted order

Hi All,

I have a webi report based on merging of 3 bex queries and 2 Universes on Fiscal Week.

In the report,I have to show all the sales related according to the fiscal week.

The fiscal week is merged and it is from BEX Query

I have a input control on Fiscal qtr.

So when i am selecting Fiscal Qtr=2.data is not coming in sorted manner.

i am getting as 15,14,16,17,18,20.........

And one more problem is if i am selecting Fiscal Qtr=4 then i am even getting the data for Fiscal Week as 1,40,41,42,43......

(Even Fiscal week =1 is also coming in 4th Qtr).

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Posted on Sep 22, 2013 at 07:10 PM

    Hi,

    A small thought here!

    You might have to have fiscal year in front of the fiscal week.

    The sort the fiscal year first and then the week,

    Later you can hide the fiscal year.

    Sorting at bex side and then bringing into webi might not work always...

    Br

    Prabhith..

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 18, 2013 at 10:45 AM

    Hii Kethireddy ,

    kindly sort the Bex Report in Bex designer based on Fiscal Week Key and then you will get sorted list

    in Webi or Dashboard and if u wanna do setting in webi then kindly use Fiscal week key object instead of text and then apply sort .

    Regards

    Jeetan

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 18, 2013 at 03:23 PM

    Kethireddy,

    Afraid this is a common problem with BEx Fiscal Weeks or Periods in Webi. I have ended up applying a custom sort on Fiscal Weeks where you will have to manually select the sort sequence of week 1, week 2......etc....etc up to week 52.

    The reason being is that Webi doesn’t see them as a time period and sorts them whether you use the key or the text as a text string.

    If you don't want to do a manual sort, you could include Fiscal Period or Fiscal Quarter as hidden objects in your table / graph and their presence will naturally sort the weeks for you,

    With regards

    Gill

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 19, 2013 at 11:40 AM

    Hi Kethireddy,

    As mentioned by Gill, Custom sort is the best way to design your report, however this will be get apply on complete document.

    In addition, if you say after applying Input controls the sorting is not working, so is Sorting working fine with the Merge dimension without using Input Controls????

    Moreover if you want to focus on workaround of this problem use Custom Sort or use Key object in query, else to understand the cause of such behavior can simply perform some below test:

    1) Keep only the objects of BEX queries in the merge dimension and test the behavior.

    2) Keep only the objects from Universe in the merge dimension and test the behavior.

    3) If you are using BI4.0 BEX option to create report, create OLAP universe on those BEX queries and check the datatype of 0Calweek (should be string) create report with merge dimension and check the behavior.

    Hope this will help to proceed further.

    Thanks

    Abhi

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.