Skip to Content
author's profile photo
Former Member

Search help displayed in webgui mode

In SRM I have create e new service. In this services i have created the template SEARCHHELP.HTML.

But when I click on search icon, start the webgui template. In template I use the "macro" F4HelpButton.

Help Me!!

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    author's profile photo
    Former Member
    Sep 30, 2005 at 09:28 AM

    Please explain your problem clearly.

    From whatever you have mentioned on this ste i cold gather following:

    1. You created a new template

    2. You want F4 help feature in that 'Z' template

    3. You wrote some macro but you are not getting the F4 help.

    Is this the correct understanding of the situation?

    If yes, please following:

    1. Have you setup a separate RFC for F4 help?

    for reasons (just know to SAP developement team only), you need to define separate RFC for pulling the F4 help from backend system

    If you have not done that, then you would not see F4 help.

    Please advise if this solves your issue.

    If this is not your issue then pplease explain in more details please

    regards

    rahul

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      I had the same problem in service BBPSC01. Within this service you can find two templates: webguisearchhelp and searchhelp. In your case, every time the webguisearchhelp is

      called.

      I never need the webguisearchhelp, so I deleted the existing

      include in webguisearchhelp and inserted the include from the searchhelptemplate:

      `include (~service="bbpsearchhelp", ~theme="99", ~language="", ~name="searchhelp.html")`

      Now the correct ITS searchhelp is displayed.

      Regards

      Dennis