Skip to Content
author's profile photo Former Member
Former Member

Filter Web Template with URL Cmd: doesn't work with compound infoobject ?

Hello all,

I've to filter the query contained on a web template with URL command, but it doesn't work.

The web template contains only one query, and on the free chars I have 0PLANT.

I call the web template adding to the normal url the following command:

&FILTER_IOBJNM=0PLANT&FILTER_VALUE=33

where 33 is the code of the plant I want to filter.

The command is executed, I think, because the result is "NO APPLICABLE DATA FOUND". The fact is that when I execute this query on the Bex filtering 0PLANT by value 33 the data exists.

May be because 0PLANT on our system is in compound with 0SOURSYSTEM ? In this case, what's the value I can use as filter ?

Thank's in advance,

Max

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 28, 2005 at 09:20 AM

    Hi,

    please see http://help.sap.com/saphelp_nw04/helpdata/en/59/edfe395dd76846e10000000a114084/frameset.htm

    especially:

    If the variant with ending 'EXT' is selected, the fully compounded value has to be entered in the external format, for example, 24.12.2000.

    If the ending 'EXT' is not used, the fully compounded value has to be entered in the internal format, for example, 20001224 for 24.12.2000.

    and

    In the internal display (see table below) you can easily determine the name of the characteristic and the filter value using the URL parameter &snippet_operations=%20 (see also Object Tag for the Properties of Web Templates). Call the Web application with this URL parameter. If you filter using the context menu, the parameters FILTER_IOBJNM and FILTER_VALUE are automatically added to the URL in the Web browser. You can then use the desired values with Command URLs in hyperlinks.

    Heike

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 28, 2005 at 11:25 AM

    Hi Massimiliano,

    you have to specify for which dataprovider the filters have to set. Add to your url DATA_PROVIDER=*&MULTI=X.

    so the full url should be:

    ...template_id=<yourtemplate>&DATA_PROVIDER=*&MULTI=X&FILTER_IOBJNM=0PLANT&FILTER_VALUE=33

    hope this helps.

    regards,

    Alex

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 29, 2005 at 06:39 AM

    Thank's Gooder, it works with FILTER_VALUE_EXT and the value in compound (for example, soursystem XX and plant 33, I've used FILTER_VALUE_EXT=XX/33).

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.