Skip to Content
author's profile photo Former Member
Former Member

Deploy to J2EE Engine EAR

Hello

I have got an EAR proyect done with SAP Netweaver Developer Studio and I want to deploy a Java proxy interface in the SAP J2EE Engine. When I try to deploy I get this error:

27-sep-2005 11:54:30 /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Thread[Deploy Thread,5,main]] ERROR:

[001]Deployment aborted

Deployment exception : Cannot determine sdm host (is empty). Please configure your engine/sdm correctly !

Where is this parameter to configure?

Do I have to install something more in my local computer?

Regards

Ger

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Sep 27, 2005 at 10:17 AM

    Hi Ger,

    to which port did you deploy?

    i think it is a wrong port.

    go to your J2EE Engine Startpage(http://xiserver:<port>/index.html) -> System Information

    there you can see your message server port.

    Regards,

    Robin

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 30, 2005 at 10:36 AM

    Ger,

    Check whether all the traffic lights are green (Server,SDM,Dispathcher).Also check the message server port(mostly it should be 3601).

    Regards

    Rajeev

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Oct 01, 2005 at 05:12 PM

    Hi,

    Check the configuration settings ur NW developer to target SAP J2EE engine. This was done using nwdeveloper studio -> windows -> preferences -> SAP J2EE Engine -> message server ( give name of message server ) and port.

    Now try to deploy it will connnect to ur sap j2ee sdm.

    I think this will helpful to you.

    Thanks & Regards,

    Mallikarjun.M

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Oct 01, 2005 at 06:01 PM

    Hi Ger

    The following thread discusses the exact problem you are facing with the appropriate fixes,

    SDM Error when Deploying Web Dynpro Application

    cheers

    Sameer

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.