Skip to Content
author's profile photo Former Member
Former Member

OM custom infotype deletion and recreation using PPCI

Hi All,

I created a custom OM infotype using PPCI. Due to complete change its structure, I deleted it using PPCI.

I tried to recreate it using PPCI. But now it is not allowing to create the custom OM infotype with same number.

It is showing up a log stating that some objects like structure, module pools do not exist for that infotype. Is it a usual behavior or I am missing something.

Now this is causing dumps in t-code PP02, PPOME and so on.

Any help to get rid of this problem will be appreciated.

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Sep 09, 2013 at 12:25 PM

    Check if TADIR entries exist.

    The TADIR entry will be deleted if the R3trans can not find any details during the export. So try releasing the request and if object is really deleted, the TADIR entry will be deleted too.

    Check this way.

    Hope it helps.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Chetan,

      You mean to say that there should be any entries in TADIR or there should not be?

      I don't want to release the transport created. This is because since the infotype structure now is changed, I decided to delete the entire infotype and recreate it using PPCI. While deleting it allowed me with no logs or error messages. But at the time of recreating it again, it is giving me a error log.

      Thanks,

      Ameet

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.