Skip to Content
avatar image
Former Member

Adobe Designer web service call has no response

I installed Adobe Designer 7.0 locally and created a form which uses a data connection to a web service for a standard BAPI.

The form designer was able to load the WSDL correctly and I was able to include the desired input and output fields as well as the submit button (which was under the data connection).

However, when I tried to run the form, nothing happens when I click on the submit button.

The properties of the button indicate an execute of a data connection and all the entries seem ok.

For verification, I tested the web service using SAP SOAP Client and everything works fine.

The web service browser is running on WebAS620 - could this be the issue? I hope not - it doesn't make sense because a SOAP call should be independent of the underlying system.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Sep 27, 2005 at 09:42 AM

    I've got the same problem. Due to my tests I can add the following:

    - The WSDL used binding type Document (when using RPC the WSDL cannot be imported)

    - I tested it on a WebAS 6.40

    - I added the sap-user and sap-password parameters to the soap address

    - The button attribute "Run at" is set to server

    - The PDF returns with "Cannot post to ''." when clicking the button.

    - The service runs fine if used from a PDF within a webdynpro, but I want to get it running from a stand-alone PDF also.

    Looking forward to any help.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Hans,

      I'm struggling with the same problem. I developed the form in SFP, I tested the web service with a third party tool, this works fine. I added a new dataconnection and imported the wsdl file. I linked the request parameter to a from field and the returns parameters to a form field, added a button with "execute" , with run at server option. I didn't check the Re-merge Form data check-box. When generating the form everything gous well, when I open the form in the reader and fill in the request parameter and push the button i still get the message :

      "can not post data to."

      I'm using Adobe Reader 7.09 and Life Cycle Designer 7.1. On a SAP ECC 6.0 SP08 system.

      Do you have example script for binding the request node to a field value ? Or a example of the additional coding you used. I'm really looking for more scripting examples because I'm a real ABAP-guy.

      I hope you have some extra information for me to solve this problem.

      Thanx in advance.

      Jasper

  • avatar image
    Former Member
    May 30, 2008 at 08:53 AM

    Dear all, I've also searched about the same problem for 2 weeks.

    What I now understand is as following:

    1. If we have not Adobe Reader Extension license as a server component or

    2. If we have not Adobe professional 8.0

    It is NOT possible to use WSDL connections to retrieve any data from R/3 databases.

    So it means that having an Adobe LiveCycle Designer and Acrobat Reader 8.0 is not enough for us. We should pay for smth to use web services integration features.

    Am I right?

    This is very bad news for me. Because I try to develop Travel Request and Expense forms via SFP transaction by copying them from standards and getting a few extra information is not possible unless I use web services. The interfaces that these forms use have huge complexity and modificitation of them seems as a nightmare.

    Are there any alternate ways for me for example calling ABAP functions by using FormCalc or JScript, etc? 😊

    Thank you for your interest.

    Volkan

    Add comment
    10|10000 characters needed characters exceeded