Skip to Content
author's profile photo Former Member
Former Member

How to set compliance level on CBS server

I am using JDK 1.4 specific keywords (ex. assert) in my code. I was able to compile in my local environment by changing compiler compliance level to 1.4 in Developer Studio.

Go to menu Window -> Preferences -> Java -> Compliances & Classfiles -> Compiler compliance level -> 1.4

Hoever, I'm getting a CBS compile error because the CBS server doesn't seem to like the JDK 1.4 keyword.

How do I tell CBS to use 1.4 compliance level instead of 1.3 which seems to be the default?



Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Sep 27, 2005 at 12:17 PM

    Hi Li,

    you have to set this in the SC configuration XML file. You can edit this file in the CMS WebUI.

    If you add the following statements to the default build variant of the XML file your source code should be compilable.

      <build-option name="javac_source14">

    Maybe you also have to set the ant_jdk_version option to JDK[xyz]_HOME that is defined in the CBS configuration of the Visual Admin.

    For more details have a look at



    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.