Skip to Content

JDBC sender adapter error

We are having an issue whilst setting up a JDBC sender adapter from XI to a SQL server hosted application. We were able to run the connection in INT environment but getting error in Pre-Prod environment. Also, XI Pre-Prod system is able to connect to target application's INT server. By XI pre-prod to target Pre-Prod is coming up with error. There is no difference on XI servers in terms of JDBC library version. Also, firewall issue is ruled out.

Below is the error log from XI JDBC adapter:

Error during database connection to the database URL 'jdbc:sqlserver://database.company.com\application_server:port;DatabaseName=INSTANCE' using the JDBC driver 'com.microsoft.sqlserver.jdbc.SQLServerDriver': 'com.sap.aii.adapter.jdbc.sql.DriverManagerException: Cannot establish connection with the registered driver. com.microsoft.sqlserver.jdbc.SQLServerDriver returns: The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: The TDS protocol stream is not valid... : com.microsoft.sqlserver.jdbc.SQLServerException: The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: The TDS protocol stream is not valid..'

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Sep 05, 2013 at 06:02 PM

    Hi,

    Please check the link below:

    http://blogs.msdn.com/b/saponsqlserver/archive/2011/12/02/microsoft-jdbc-driver-1-2-sqljdbc-driver-fails-to-establish-secure-connection.aspx

    Specifically the context:

    This is a known issue of this version of the Microsoft JDBC driver. This version of the driver cannot use SSL if the SQL Server uses a certificate that is larger than 4KB. Even if the NetWeaver AS Java does not use SSL to connect to your SQL Server, the login information (user and password) are still encrypted.

    The recommendation is to switch to a newer version of the Microsoft JDBC driver. This solution is valid for SAP systems based on NetWeaver 7.1 and higher.

    It also refers to SAP Note 1428134.

    Hope it helps!

    Ambrish

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 05, 2013 at 09:42 PM

    Your jdbc driver is not valid. Please go to microsoft site and search for the latest version. But you have to keep one thing in mind that driver versions are based on JDK. Again PI versions are again based on JDK too. If you use 7.0, you need jdk 1.4 or less whereas if you use 7.1 and above, you would use jdk 1.5 +. So based on PI/java versions you have to use the corresponding sql server jdbc driver. Hope that helps.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.