Skip to Content

SOAP lookup UDF not working

Hi,

I have written a UDF for soap lookup(PO7.31), its is going to BRMS and coming back with rules.

My issue is: If I run my message mapping i am getting proper output from lookup, But same if i call from WS Navigator, it is not at all calling BRMS system, even I ve checked in soap lookup receiver communication channel, it doesnt capture any call from WSNavigator. but it does if i locally run message mapping.

Need you support.

Best Regards

Rohit

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Sep 05, 2013 at 02:02 PM

    I have resolved the problem.

    Although all the fields were not mandatory in UDF but still when I havn't passed values to some it was not calling UDF itself.

    Once I provided values to all the fields then it worked.

    Thanks for all your support.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 05, 2013 at 01:06 PM

    Hi Rohit,

    Check if there is any validation for the SOAP request (like wsl cookie validation).

    Thanks,

    Partha

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Partha,

      Right now I found that the UDF which I have written in Message Mapping is working locally but it is not even being called through WS navigator.

      As well as where I can check for wsl cookie validation??

      Thanks

      Rohit

  • Sep 05, 2013 at 01:17 PM

    Hi Rohit,

    Can you explain your scenario...

    Regards

    GAgan

    Add comment
    10|10000 characters needed characters exceeded