Skip to Content

TREX setting error <local gw> 0 ms *** ABAP ERROR: <no response>

I am trying to connecting the TREX in Windows Server with SQL server 2008 to Development Server (iseries).

The TREX was connected to QA server on client 210.

And now I'm trying to move the TREX connection into Development server on client 110.

In TREX administration server, I have setup the Connection and successfully create the RFC destination (sm59).

Check from SM59, new RFC TREX_60 has been created.

But the problems are:

1. From TREX administration

Once click the Connect Admin Tools & Repair All, it return an error:

<local gw> 0 ms *** ABAP ERROR: <no response>

<local gw> Not set in TREX

2. From Backend > SM59 > TREX_60 > Connection Test return an error message:

Logon Connection Error Error Details Error when opening an RFC connection (CPIC-CALL: 'ThSAPOCMINIT' : cmRc=2 thRc=67 Error Details ERROR: program Trex_ECD_20130905183201 not registered Error Details LOCATION: SAP-Gateway on host bnvs20 / sapgw10 Error Details DETAIL: TP Trex_ECD_20130905183201 not registered Error Details COMPONENT: SAP-Gateway Error Details COUNTER: 1106621 Error Details MODULE: gwr3cpic.c Error Details LINE: 1833 Error Details RETURN CODE: 679 Error Details SUBRC: 0 Error Details RELEASE: 720 Error Details TIME: Thu Sep 5 18:43:43 2013 Error Details VERSION: 2

This problem doesn't occurred in QA and Production server, which has the same server specification.

Any advice will be appreciated, thank you.

Best Regards,

Ady Purnama

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Sep 17, 2013 at 05:04 AM

    Hi all,

    just found the answer, it closely related with this thread:

    We are using kernel 720, this is the reason there's no rfcexec anymore.

    When look at profile parameter RZ10, default profile, it stated that gw/acl_mode = 1, while gw_reg_info and gw/sec_info didn't maintained.

    So the solution is: change the value into gw/acl_mode = 0, restart the server, done.

    Thank you,

    Ady Purnama

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 09, 2013 at 09:46 PM

    Hi Ady

    I have seen this type of issue before and it was caused by incorrect setting of the reg_info and sec_info files. Please read the following note for more details.

    1757655 - RFC failure - Cannot register TREX/BIA Registered
    Server Program with Gateway

    This note suggests apply the recommendations outlined in the following gateway note

    1408081- Use basic settings for reg_info and sec_info.

    Please apply this note and see if the RFC connection works afterwards

    Kind regards


    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Barry,

      thanks for your reply.

      Both notes seems applicable for BW and using central SAP Gateway?

      I've tried to implement the note, but cannot be implemented.

      I forgot to mention, that I use this TREX to support Enterprise Portal especially for Talent Management module - not for BW; and use local gateway not central SAP gateway.

      Do you have any experience on the same case?

      Thank you,


  • Posted on Sep 10, 2013 at 02:21 AM

    Dear Ady,

    Please find the step how to Create a SAP System User for the TREX Admin Tool (Stand-Alone) in the link below:

    And please ensure that you have go through this step completely.

    Thank you very much, hope it helps.

    Best Regards,


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.