Skip to Content

Using Smartstyles in Smartform

Hi Experts,

I'd like to ask your assistance in a simple problem in using smartstyles. I have a project where I'll use the standard form SEPA_MANDATES (I created a custom form ZSEPA), now the problem is I would like to make spaces between each category (see screen shot spaces.jpg) the standard line space is too big.

I would like to make atleast half of the standard line (space when entered). I know to do this we should use smartstyles paragraph format, but in this case when I tried, I get a pop up "Unpermitted character formats being deleted" (unpermitted.jpg)

When you click ok, the form is ruined. can you please help me apply the spaces I need?

Please create a copy of the standard form SEPA_MANDATE, then when you try to use smartstyles, these popups will trigger...

Thanks!

Jeffrey Broodwar

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

9 Answers

  • Best Answer
    Posted on Sep 05, 2013 at 12:06 PM

    Hi Everyone,

    Thanks for your help, I solved the problem. instead of making a line between customer and address and putting Z in between, I placed the paragraph format in the last line where the partition should start. see screenshot below. I used space after instead of line spacing.

    I used to make blank space in the red line's location above then put Z instead of asterisk. This didn't do any good. instead I placed my created paragraph format before the last line (boxed above) having space after value set, this made the space I need. trial and error made it right.

    Thanks for all the help, Anyway I got a last question, when I try to click and try to put a new paragraph format I still see a message saying that my custom style( configured to both form and text nodes) not available...

    Why is this message being thrown?

    Again, thakns for all the help.

    Thanks,

    Jeffrey Broodwar


    Solution.jpg (77.8 kB)
    Not available.jpg (52.4 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 04, 2013 at 05:14 PM

    you haven't included the smart style in smart form...have you? this usually come when form doesn't recognize character/para format because of non-availability of style. pls check.

    Rgds

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 04, 2013 at 05:32 PM

    The standard doesn't come with the smartstyle. anyway I searched for smartstyles and found SEPA_MANDATE_STIL, copied this to my own Z style. now, I created a z paragraph format...I cannot use this in the change editor window (instead of asterisk I want to use Z but a message pops saying zsepa_mandate_stil not available) why is this?

    Also I have attached the missing attachments in my original post. ( I cannot post attachment, I'm receiving error "The content type of this attachment is not allowed) trying to post a jpeg file... wierd.

    Thanks,
    Jeffrey Broodwar

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 04, 2013 at 05:46 PM

    Jeffrey screenshot is missing:-(

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 05, 2013 at 03:17 AM

    Hi Jeff,

    save and activate your Smartstyle, after this your style should work. You can also insert an empty line after your adress to get enought space.

    Cheers

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 05, 2013 at 04:07 AM

    Hi,

    First you create the Smart style in the TCODE smartforms with the required format which you want.

    And then use this style in the Output options of the form.

    Thanks

    Pavan.N

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 05, 2013 at 05:30 AM

    hi ..................jeff broodwar

    I have tried the same nd i am not getting any popup .................

    1 please check which style you are using in smart forms.

    goto- Form attributes-> output options in your zee form and check whether the style is zee or standard .......... if it is standard one copy this in a zee style and replace it in your zee form.............

    now in that zee style create paragraph format and activate it ,then it will be available in text element....


    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 05, 2013 at 05:32 AM

    Hi Jeff ,

    The problem would be the character format you have created and used in the smartforms . If you could attach the text editor where you have used the style formats. Simple for line space we usually no need for style . For the space as mentioned in the discussion empty paragraph could be used .attach the close the discussion if you have complete the task .here i will attach screen for reference.

    regards,

    sanjith n


    test.JPG (36.3 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member jeff broodwar

      hi jeff,

      Nice to see your reply .first the unpermitted character format error rectified is it ?

      then what you have mentioned is correct that instead of * you used 'Z'.

      To confirm this style is working first try to apply the smartstyle globally as displayed below .

      If that doesn't work try the next option as shown in the image .

      the above mentioned is for particular text specially a style has been used .

      Finally no reflection in the output as expected just increase the line spacing in the style . this is just to check the smartstyle is working or not.(Note : you can give more line space and check.for testing purpose only )

      you can also check the line space by taking the printout .because in the printout you may get the expected space by simply using standard *.

      NOTE : in the style header data you will name the standard paragraph format .It will be considered when you are trying to use * in paragraph format this could be confirmed by using BOLD in the style .Feel free to ask any doubts .

      Regards,

      Sanjith N

      gl_style.JPG (41.7 kB)
      local_style.JPG (44.1 kB)
  • Posted on Sep 05, 2013 at 08:11 AM

    1 more thing, when I try changing * to Z, I search for the paragraph format I created Z, but I get the message

    ZSEPA_STYLE not available...


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.