Skip to Content
0

Custom tile not opening configuration page

Jan 12, 2017 at 11:17 AM

141

avatar image

Hello,

I am trying to implement a custom Fiori tile for the launchpad designer but the configuration page of my custom tile doesn't open.

As a first step, I tried to create a custom tile using the exact same files than the dynamic app launcher. So I copied the chip /UI2/APPLAUNCHER_DYNAMIC to a new one called ZXXX_CUST_TILE :

Then, I enhanced the catalog /UI2/FLPD_CATALOG from the WebDynpro component /UI2/CHIP_CATALOG_CONFIG like this :

As a result, I can now see the custom tile type in the launchpad designer :

But when I select this custom type, I am redirected to previous screen showing different tiles in the catalog, and no configuration page is opened...

Can you please explain me why my copy of the standard chip is not working ?

Thanks a lot for you help

Francois

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Francois Mesmacque Jan 19, 2017 at 10:39 AM
0

I have found what was wrong. I copied the wrong chip.

On first screenshot we can see what is the chip related to dynamic tiles : /UI2/DYNAMIC_APPLAUNCHER

And if you open this chip, you can see it is not using the file chip.xml that I used.

The good file is located at : /sap/bc/ui5_ui5/ui2/ushell/chips/applauncher_dynamic.chip.xml

Regards

Francois

Share
10 |10000 characters needed characters left characters exceeded