Skip to Content
0
Sep 04, 2013 at 02:11 PM

Default Rule in Standard Task is not working in Workflow

811 Views

Agent Determination Issue in Workflow

Hi Experts,

I'm using an activity step and where I am assigning agent using a workflow container element. I have also assigned a default rule to task of step in case workflow does not fetch any agent for that step. While running the workflow the default rule is not working, workflow log shows below error :

Agent determination for step '0000000023' failed;

Result of agent resolution does not agree with agents of task;

When I tested task alone through SWUS, rule worked fine and proper agent got assigned from the rule. But when testing it through workflow, rule doesn't seem to work. I seached on SCN and found similar issue in below mentioned thread

http://scn.sap.com/thread/1929785

I tried but couldn't find out the solution.If anyone has faced such issue earlier then please let me know what could be the possible reason.

Rule works fine in Simulation and Standalone run of task but does not work in workflow.

Thanks,

Vishesh