Skip to Content
author's profile photo Former Member
Former Member

Loadings missing sales documents

Hi,

I am loading my test environment but are facing some issues. The datasource I extract from is 2LIS_11_VAITM, but in the test environment I am missing sales documents. These are of a specific sales order type, and I am missing sales documents >= 70000000.

This is working just fine in production, and in the VBAK table all sales documents are there. Have tried to delete the setup tables (LBWG) and reload them (oli7bw) but still the records wont be loaded into BW. The only filter I use is on year, but there is alot of records with >=70000000 and the sales order types for the selected periods.

Have tried initial load with data transfer and full load on my info package, but nothing seems to do it.

Does someone have any suggestions for whats causing this problem?

Add a comment
10|10000 characters needed characters exceeded

Related questions

7 Answers

  • Best Answer
    Posted on Sep 04, 2013 at 11:03 AM

    Hi

    I don't think you have an extraction problem here. Since the documents are comming your approach is correct. You said the sales documents past 7000000 are of a specific sales order type.

    Have you checked the setuptable itself? Tx Se16 MC11VA0ITMSETUP are the docuuments of that range in there?

    I recommend to check with a function if the customizing is done the same for that sales order type. Maybe in Tx OVAZ its not allowed for that salesorg

    hope it helps

    Martin

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 04, 2013 at 08:54 AM

    Run RSA3 in F mode to see records are coming?

    Run init W/O transfer

    Then run repair full with out specifying data selection.

    Have you scheduled V3 job(JOb Control in LBWE) for delta loads to BW?

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 04, 2013 at 10:04 AM

    Hi ,

    1. Verify whether the documents that you are looking for are they available in the application tables you are testing.

    2. If yes then Fill setup tables and then run the extractor in RSA3 with full mode to check if the same are coming or not.

    3. If it is coming in RSA3 then there is no reason why the same will not come to BW.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 04, 2013 at 11:14 AM

    Hi Kjell,

    Can you try to take any one missing document number for the testing and check whether its coming in RSA3 extractor after deleting and filling up the relevant setup tables.

    The outcome of this activity will define the our next course of actions.

    Br,

    Arpit

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi

      MC11VA0ITMSETUP is a cluster table, you cannot see data directly here..

      RSA3 has a field called Data Records / Calls and Display Extr calls... are they in default settings?

      of 100 and 10 respectively? Then RSA3 would only extract 100X10 = 1000 records.

      A report RMCEX_SETUP_ENTRIES ( from SE38) can give you number of records in setup table per application component, but there might not be one to one mapping with extractor checker.

      Cheers

      Anindya

  • Posted on Sep 10, 2013 at 11:55 AM

    Hi,

    Try to fill the setup tables for small - small chunks. use the selection fields when you filling the setup tables with the help of Sales Organization, Company code and SD document.

    Try it ones may be it will help you.

    Regads,

    Satendra

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 10, 2013 at 01:03 PM

    Hi

    Take the help of any ABAPer and use rsa3 extraction through ABAP debugger. Put some breakpoint in the code. You would be able to understand whether the records are being extracted or not and if yes then where are they getting removed. This will help you surely to pin point the issue. Many a times when issue like these come, we debug through rsa3 and we get the list of data being processed and if we find some data missing then we are able to find the point of the code.

    Hope this helps.

    Mohamed Shadab

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 10, 2013 at 04:38 PM

    Hi,

    If you filled the setup table then first check in MC11VA0ITMSETUP setup table in SE16. If the document is present here then pull the record in INIT WITH DATA TRANSFER in BW.

    If the record is not present then there is some problem in filling setup table. Check in SM37 whether the setup table filling is completed successfully.

    Regards,

    Debabrata

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.