Skip to Content

TR Log file size for a single record

Hi Experts,

I have total number of 31,02,541 records in cube(0IC_C03) in my BI production system. I'm compressing those records which is generating some TR log files in LOG_DIR folder. when it(log_dir ) reaches 6GB it is throwing a dump like TR Log backup is Full.

Could u please advice on this issue how much i need to increase the log directory size.



Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Sep 03, 2013 at 01:10 PM

    Hi Shan, I suspect the Primary log becoming full on your database. If the file system "log dir" does not reach 100% when you compress the data, check the parameter LOGFILSIZ and LOGPRIMARY and LOGSECOND of your database.

    On my BI server, I had to grow up the LOGFILSIZ to 196608 (768 mb) per log when doing compression stuff. But I raise these parameters par slice of 256 mb. You have to restart the database when changing these parameters.

    For the size of the file system you have to calculate LOGFILSIZ * LOGPRIMARY. As an example, my LOGPRIMARY=60 and my LOGFILSIZ=196608 (4 KB).

    If you have LOGSECOND, you have to put this in the calculation too but it's zero by default.

    The size of my my file system will be 47 gig.

    Let me know

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 03, 2013 at 11:34 PM

    Hello Shan,

    Regarding of log space consumption for infocube compression, it is possible to make some estimation.

    This will need some more information like the average row size of the fact tables, and the size of the indexes and etc. Anyway, a detailed analysis is needed. I suggest to create a CSS ticket for further help.

    Thanks and kind regards


    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 03, 2013 at 09:03 AM

    Hi Shan,

    Please check whether log_archmeth1 parameter is set in your database.

    This parameter should point to another partition log_archive.

    When this parameter is active, at the time log_dir reaches threashold value , system will transfer the log files from log_dir to log_archive.

    You need to actively take backup from log_archive and ensure this partition has enough space.

    Hope this helps.


    Deepak Kori

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Deepak

      It is case for exceeding transaction log size for single operation without commitment. In db2diag there is "saturation point reached error".It is not possible to archive those logs cause they contain uncommited transactions.

      We had such issue in the BI system while compressing cubes and SAP asked us to multiply t-log by 5 to 10 !!!



  • Posted on Sep 03, 2013 at 10:13 AM


    Please check your logarchmeth1 parameter. if its not set use below command and set.

    db2 update db cfg for SID using LOGARCHMETH1 DISK:/db2/SID/log_archive

    You can delete logs from log_archive after getting backup if its getting fill.



    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 07, 2013 at 05:19 PM

    Hi Shan ,

    COuld you paste here output of command ,

    db2 get db cfg for <DB> | grep -i log

    and what is size of log_dir and log_archive ? if we can change the size of some logging paramter your issue can be solved.


    Manas Behra

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.