Skip to Content
author's profile photo Former Member
Former Member

Unable to activate activities in DTR

Hi All,

I am having problem while activating the activities after checkinh them in. The Activation log says "No build log available. The DC has not been built in this request."

Regards

Prakash

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Sep 26, 2005 at 08:06 AM

    Hi Prakash,

    Can you login to CBS and check against the particular buildspace what is the status of the activation request. Also just check the status of the buildspace itslef.

    Regards

    Sidharth

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 26, 2005 at 09:51 AM

    Hi Prakash,

    As Sidhart mentionedm in Component Build Service GUI check the status of build spaces if activiated it shows a green right tick mark.You can also check the Activities link to see the activites in a particular buil space.

    Regards,

    RK

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Sidharth Deshpande

      Hi,

      Below is the error that i am getting

      Build number assigned: 942

      Change request state from QUEUED to PROCESSING

      BUILD request in Build Space "MA_TCTAWA_D" at Node ID: 1,910,150

      [id: 926; parentID: 0; type: 2]

      REQUEST PROCESSING started at 2005-09-29 10:07:29.021

      ===== Pre-Processing =====

      Calculate all combinations of components and variants to be built...

      "sample.com/ma/load" variant "default"

      "sample.com/ma/load" variant "default" IS BROKEN. The component therefore cannot be built and will be marked as BROKEN.

      [DC 177 variant "default"][SC 110 "sample.com_CTAWA_1"][last successfull build: 0]

      Prepare build environment in the file system... started at 2005-09-29 10:07:29.521

      Synchronize development configuration... finished at 2005-09-29 10:07:29.662 and took 140 ms

      Synchronize component definitions... finished at 2005-09-29 10:07:29.663 and took 0 ms

      Synchronize sources... finished at 2005-09-29 10:07:29.664 and took 0 ms

      Synchronize used libraries...

      Synchronize used libraries... finished at 2005-09-29 10:07:29.665 and took 0 ms

      Prepare build environment in the file system... finished at 2005-09-29 10:07:29.666 and took 145 ms

      ===== Pre-Processing ===== finished at 2005-09-29 10:07:29.668 and took 576 ms

      ===== Processing =====

      BUILD DCs

      ..SKIPPED. Nothing to build.

      ===== Processing ===== finished at 2005-09-29 10:07:33.119 and took 3 s 445 ms

      ===== Post-Processing =====

      STORE build results...

      "sample.com/ma/load" in "default" variant is BROKEN. No build results to store.

      "sample.com/ma/load": store meta-data

      "sample.com/ma/load" in "default" variant is PROCESSED

      Change request state from PROCESSING to SUCCEEDED

      Analyse effect of applied changes to buildspace state... started at 2005-09-29 10:07:33.178

      INVALID DEPENDENCIES: The following dependencies of the DCs in this request are being marked as invalid as they refer to non-existent public parts.

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/tc/ddic/metamodel/content [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: telstra.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/tc/wdp/metamodel/content [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/tc/ddic/ddicruntime [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/tc/cmi [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/com.sap.aii.util.misc [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/com.sap.aii.proxy.framework [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/tc/bi/bp/webDynpro [public-part: webDynpro] AS Build Plugin Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/tc/logging [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/com.sap.exception [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/com.sap.security.api.sda [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/tc/wd/webdynpro [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      DC: sample.com/ma/load of compartment sample.com_CTAWA_1 USES UNKNOWN DC: sap.com/com.sap.mw.jco [public-part: default] AS Build-Time Dependency

      [validity: USED COMPONENT OR PUBLIC PART IS UNKNOWN OR UNDEFINED]

      Handle Cycles...

      No cycles detected.

      Determine components that have become DIRTY due to the results of this request...

      No such components have been found.

      Analyse effect of applied changes to buildspace state... finished at 2005-09-29 10:07:33.729 and took 551 ms

      Request SUCCEEDED

      ===== Post-Processing ===== finished at 2005-09-29 10:07:33.731 and took 580 ms

      REQUEST PROCESSING finished at 2005-09-29 10:07:33.732 and took 4 s 711 ms

      It shows that all the standard DC's which are used are missing. I am also getting error in the Used DC section that all the above DC's are deleted.

      I tried to add the SC again but it still didn't work. Any idea how to add those back.

      Regards

      Prakash

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.