Skip to Content
author's profile photo Former Member
Former Member

Table controll is filled with the wrong collumn sequence

Hello,

I currently have a problem with a tablecontroll: The Sequence of the collums is wrong.

As you can see, in the elementlist the sequence of the fields is as follows:

1 waers (währg)

2 Date_from (Beginn)

3 Date_to (Ende)

4 GRPLIMIT (Gruppen Limit)

The Screen-Painter reflects that:

When I diyplay the screen as a Test in SE80, I get the correct sequence:

When I want to use that view in my Viewcluster however, it always displays like this:

When I check the tablecontroll with the debugger, it looks like this at PBO:

(Displaying waers at index 4 instead of 1....)

When I change the index Positions using the debugger, I get the correct results, but that can't be the solution...

I used SE11 to create the view, SE54 to create the Dialog (SE54 again to create the Viewcluster)

The Sequence of the fields in the View are also exactly the same as they should be in the view itself...

There are about 20 Views in that cluster and this is the only view with that problem...

What can I do to fix this?

What do I need to do, to avoid this in the future?

Btw:

- When I delete a field from the viewscreen using screen painter, the view in the cluster will refelct that.

- When I add the same field again at a different place, the view cluster will show it at the same place as above (which is the wrong place from my point of view...)

- I also tried to get the table controll to display all four collumns as fixed (which works fine with the other screens), but here it will revert back to its original 2 fixed collumns.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Sep 03, 2013 at 08:32 AM

    Did you check table TCVIEW, "Table control views (user settings)". This table stores the order of columns in table control, there is a dialog maintenance available in SM30 too.

    For reference there is a FAQ at Note 121550 - User settings table control.

    Regards,

    Raymond

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      THANK YOU!

      THIS seems to be exaclty right!

      In this table there are wrong entrys for the old table controll!

      (I do not want to rewrite everything again, so I will not implement the old solution once more and check, if this really is the solution, but it seems to be)

      I assume this issue to be closed now, thanks again!

  • Posted on Sep 03, 2013 at 03:03 AM

    Hello Carla Klappstein.

    Check if any default variant is set for that table control by clicking the CONFIGURATION button provided at the top right hand corner of the table control

    Regards.


    a.jpg (45.4 kB)
    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Carla.

      If you are seeing the wrong sequence on clicking Administrator tab, someone would have altered(dragging the columns using mouse) the table control columns sequence and saved that setting as standard setting.

      You can test it by changing the column sequence and create a new variant and make it standard setting.

      This standard setting will overwrite the sequence of columns created in the program.

      That's why you are facing the issue.

      a.jpg (38.6 kB)
  • author's profile photo Former Member
    Former Member
    Posted on Sep 03, 2013 at 07:23 AM

    Just for everyone who might have the same problem one day, I found the following solution:

    The Screen had been used with the older (now wrong) layout.

    Somewhere this layout had still been saved (don't ask me where, I wasn't able to find it...)

    In the end I deleted the old view, and created a new one, with a slightly different name (instead of finlimgrpv it is now finlimgrv) -> Now it works the way it is supposed to.

    If anyone ever finds the spot, where the wrong layout is still saved, I would appreciate the information.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.