Skip to Content
author's profile photo Former Member
Former Member

The import map is not complete

Hi,

Recently I have got a requirement to map a particular field in one of the Import Maps. This particular map is being used by many ports.

I have done the mapping and tested it for all the ports. For processing via MDIS, kept the source files under the respective ports - Ready directory which were being processed for all except one port.

The error is

<Error ts="2013/08/01 19:09:54.005 GMT" tid="8" entry-no="28255">The import map is not complete:<LF/>1. Missing the XML Root Element.<LF/>2. There are multiple root elements defined in the xml schema.<LF/>Solution: Please select the proper root element via the IM GUI then savethe map.</Error>

For rectifying this, I have done the following tasks

1. Followed the steps by the SAP NOTE 1361302

2. Compared and Checked for all the fields In the source file with XML schema file

There is no problem with the Import Map or with the source file. It gives error only after mapping a particular field.Through Import GUI, I can able to import the data, but not via MDIS.

Thanks,

Sridhar T A


Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 05, 2013 at 07:45 AM

    Hi Ravi / Thamizh,

    The issue is solved.

    In Import Manager GUI, now I used the below option

    1. Connection type : XML schema (Previously I used XML for uploading the Input file)

    2.Remote system : Selected according to the configuration maintained in Console

    3. XML Schema : Selected the correct Schema file

    4. File Name: Selected the Input XML file

    5. Root: Here I have selected the proper root element.

    In XML schema file, I found XROOT as main root element and EMPROOT as sub element. Now I have selected the proper main root element, then after the file is opened, I have selected the import map, mapped the field, saved using save update option.

    Now the files are getting loaded via MDIS successfully.

    Thanks for the support.

    Regards,

    Sridhar T A

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Sep 02, 2013 at 10:26 AM

    Hi Sridhar,

    Did you do a save update on the map?

    Please update on the details of field causing issue.

    Thanks,
    Ravi

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Thamizharasi Nagappan

      Hi Thamizharasi,

      thanks for the comments. Already I have done all the tasks which you have mentioned. I have separately compared the XML schema file with the input file. For all the other 48 ports it is workign good even after mapping the required field. but this particular port is giving error.

      I am sure there is no problem with the source file. I have restarted the MDS also.

      Trouble shooting with other ways. Will update.

      Thanks,

      Sridhar T A

  • author's profile photo Former Member
    Former Member
    Posted on Sep 05, 2013 at 08:29 AM

    Hi Sridhar,

    Can you please attach image of this port details from console.? If you claim that source file and import map are working absolutely fine via Import Manager and problem exists only through MDIS then i wonder if this port has any issues within its detail. Not sure, just a mere try!

    Regards,

    Ali

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.