Skip to Content
author's profile photo Former Member
Former Member

BCM 7 SP5 and ineffective user template recording setting

Good afternoon!

Has anyone else besides me encountered a situation where settings from user templates didn't apply correctly?
My specific problem is with a fresh 7.0 SP5 installation that began out as SP4 installation. When I try to enforce client-side recording through the user template, the setting doesn't apply or at least it doesn't work correctly.

Every voice-only agent's call is supposed to be recorded locally to a UNC share. It is also supposed to be forced on without the option for the user to disable it:

Under the user created with the created template the view looks like this:

On mouse-over the set default values are correct (default: 1 for the enabling tick and the correct recording path for the path field).

When I log the fresh user in, the first thing that one sees is that firstly there still exists a "recording" tick (which works - when not ticked the system won't record) and it is not ticked by default:

Under the Tools -> Settings -> Phone the view is as follows:

I don't know what to make of this. Is the system malfunctioning or have I done anything wrong?

Best wishes,
Jaanus Piip

template.PNG (6.3 kB)
user.PNG (4.6 kB)
newuser.PNG (12.7 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 29, 2013 at 08:45 AM

    Hello.

    I think you are doing everything right. In my opinion "Enable Client-Side Recording" just enables that tick in user interface and user must switch it on or off. Deny User-Level modification should mean that user can't disable/enable that client side recording feature, not force it to use that. However user can't disable that feature from CDT anyway.

    I tried it in 7.0.3100 and got same result. Where did you see that tick forced? Maybe they have changed functionality in newer versions.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Honestly I don't remember actually ever seeing forced client-side recording in action with BCM 7.0.
      I presumed based on the variable names' that they were supposed to force the setting on.

      If this configuration doesn't force the setting on, is it even possible to force it or at least hide the tick-box from the end-user?

  • author's profile photo Former Member
    Former Member
    Posted on Aug 29, 2013 at 10:36 AM

    Hello Jaanus,

    if you want to record every call, better to use server side recording.

    In SC go to System services>Recording settings:

    change file location to your UNC share and select a Recording mode: Forced or Forced and hidden.

    Be sure that the windows users have access to this share point.

    BR,

    Anton

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.