Skip to Content
avatar image
Former Member

IdM SAPUI5 issue

Hi,

I want to use the new SAPUI5 interface. After deploying the software, the issue is:

I read, I have to user NW 7.3 SP9 Patch 1, so I installed

IDMREST08_0-10012908.SCA

IDM_UI_HTML508_0-20011003.SCA

J2EEFRMW09P_7-10007935.SCA

J2EEAPPS09P_2-10007934.SCA

UISAPUI5JAVA09P_9-20010356.SCA

SRUI09P_1-10008070.SCA

ODATACXFEXT09P_2-10012140.SCA

Have I got all packages for my NW 7.3 SP9? Or must I set a value, because my SAP_MASTER_IDS_ID is 2.

Best regards,

Hans

error.png (24.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Aug 30, 2013 at 06:41 AM

    Hello Hans,

    IDM UI5 access the IDM DB via REST interface version 2, and the REST interface also use the identity store specified in property com.sap.idm.jmx.idstoreid of tc~idm~jmx~app. So if this is set correctly, there should be no problem for UI5 to access it.

    Have you also checked the AS Java default trace for any more detail error or exceptions when this happened?

    BR, Keith

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Keith Zhang

      Hello,

      The issue was solved after I installed the packages:

      ICDESIGNTIME08_2-10009681.zip

      IDMIC08_1-20005939.SCA

      Best rgards,

      Hans

  • Aug 27, 2013 at 02:00 PM

    Hello Hans,

    The SAP_MASTER_IDS_ID should not matter (as long as it is correct) 😊

    Make sure that all of your UI5 components are compliant.  I believe you need to be using 7.31 SP 9 at the least.

    Matt

    Add comment
    10|10000 characters needed characters exceeded

    • I updated selected components. I wound up using 7.31 and I think I went with SP09 due to the fact that some of the components I needed were only updated in 9 and I think it was the latest available at the time.

      Life is much easier when you are building a new instance for DEV purposes only 😊 Much more freedom to install and updated as needed.

  • avatar image
    Former Member
    Aug 28, 2013 at 10:25 AM

    HI,

    I read, that I need

    OData-Bibliothek (odata4j) Version 0.7 erforderlich. Die erforderliche Bibliothek ist als AS Java-Erweiterung ab SAP NetWeaver Version 7.3 SP9 Patch 1 und EHP1 für SAP NetWeaver 7.3 SP6 Patch 3 und wird automatisch, wenn die REST Komponente entfaltete.

    But, where can I see, if odata4 is installed.

    Best regards,

    Hans

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Ok, i have installed


      ODATACXFEXT09P_2-10012140.SCA Patch for SAP ODATA4J+CXF-REST LIB 7.30 SP09

      So, I have all components.

  • Sep 26, 2013 at 11:06 AM

    Hello Hans,

    don't forget to mark your last post as correct, so that others with the same problem can find this solution. 😊

    Regards,

    Steffi.

    Add comment
    10|10000 characters needed characters exceeded