Skip to Content
author's profile photo Former Member
Former Member

production issue : syntax error in setting variables in BPS0

Hi,

when our end user tried to set variables in BPSO, following error

is coming up.

Explicit length specifications are necessary with types C, P, X, N und

W in the OO context.

syntax error in program

/1SEM/CL_CHALEV_xxxPLANAREA===CP

in include

/1SEM/CL_CHALEV_xxxPLANAREA===CI

in line 5.

(where xxx = client & PLANAREA = technical name of a planning area)

then, when I checked into BPS0, I'm also getting same error.

no change has been made to this planning area.

Could some one help me where should I look for this?

We recently upgraded BW & BASIS support packs. does this cause this?

I opened a OSS note but greatly appreciate if some one share your experiences.

Appreciate any quick help.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 23, 2005 at 08:42 AM

    Hari,

    Look at note 412101 too.

    Rael

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Rael,

      thanks for your reply. SAP also recommended the same note 781371.

      unfortunately, we are still on SEM3.1B .

      We are still having same issue even after implementing the note.

      We've this problem when we tried the following.

      clicking on "Set Variables" in BPS0 for all areas.

      clicking on variables tab in only 4 plan areas but remaining areas are working fine.

      interestingly, 2 of these plan areas pointing to basic cube & other 2 multi areas have these 2 basic plan areas included in them.

      Overall, looks like the issue is including basic cube in the plan areas. (but, it used to work fine before our Support packs import).

      Do you have any other ideas.

      Appreciate your help.

  • author's profile photo Former Member
    Former Member
    Posted on Sep 23, 2005 at 07:52 AM

    Hi Hari,

    The problem has to do with regenerating the SEM program classes after an upgrade.

    I hit this problem back on SEM3.1b and I used the program "Upc_generate_class_error" to fix it. But I don't think this program exists in higher versions i.e. BW Planning etc..

    Look at note 781371. I think function module "UPC_GENERATE_AREA" (SE37) might do the trick for you.

    Good luck.

    Rael

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 27, 2005 at 02:09 PM

    Hi Hari,

    Sorry but I am away for a few weeks and don't have access to a system to answer your question.

    I recommend opening a high priority note on the OSS and SAP should be able to sort this out promptly.

    Regards,

    Rael

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.