Skip to Content
author's profile photo Former Member
Former Member

How to Undeploy JDI

I incorrectly installed (deployed) JDI SP13 on WAS SP9. I am not trying to undeploy (uninstall) JDI SP13 so I can install a JDI SP9. How do I undeploy the JDI? (How do I identify the services that are the JDI that I need to undeploy in the SDM?)

Barry Beer

MomentumSI

Austin, TX

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Sep 22, 2005 at 05:01 PM

    Hi Barry,

    When you login to SDM under the tab SDM repository in the left hand pane open the node for SAPJ2EEEngine. There you can find the SCA's that you deployed.

    For eg you will find SAP_DEVINF. In the right hand pane you will find the SDA referenced, the name of the SCA file that you had deployed and more of such info.

    However i will advice that you be very careful when undeploying because these things can bring your server down.

    Also if you can please ask SAP regarding the fact that if you now deploy JDI SP9 will these applications be overwritten. That way your work will be less and you also breathe easy.

    Hope this helps.

    Regards

    Sidharth

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Sep 28, 2005 at 12:41 PM

    Hi,

    You can forcefully deploy the older version of JDI to overwrite the existing one. This would just require making a setting in the SDM.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      There are two option available first is as suggested by Bhuwan Lodha. i.e you have to forcefully undeploy it by using SDM tool in that you have to make few clicks.

      but i am not sure it will work because these SCA creates some Database table inside WAS so you can not undeploy these SCA's complitly.

      second option i would say is to upgrade your WAS to SP13 this might me a good option but for this you have to upgrade your NDS also.

      hope this might help.

  • author's profile photo Former Member
    Former Member
    Posted on Sep 28, 2005 at 01:37 PM

    Hi,

    If you wish to play safe and undeploy-then-deploy, here is a list of components to be undeployed -

    tc.CBS.Service

    tc.CDS.DBDefs

    tc.CBS.CommonPart

    tc.CBS.API

    tc.CBS.WebUI

    tc_SL_SDM_Client

    tc/SL/CMS/PCS/DBSchema

    tc/SL/diindex

    tc/SL/CMS/PCS

    tc_SL_SDM_Util

    tc/SL/CMS/WebUI

    tc/dtr/dbschema

    tc/dtr/enterpriseapp

    tc/SL/CMS/TCSEar

    tc.CBS.Appl

    tc/cbs/cbsbuildplugins

    Best regards,

    Bhuwan

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.