Skip to Content
avatar image
Former Member

Issue While Sending Messages with HTML Content from Mail Adapter

Hi,

I am facing currently an issue, where I am trying to send a mail from PI in HTML Format, using Mail Reciver Adapter (using Mail Package,) my mail content & attachment is found empty.

Details on My scenario, the scenario is on pattern of File to RFC to Mail adapter, I am picking an XML file do some transformation post it to BAPI and get the response to a user via Mail adapter. My scenario works and I am able to populate the email Headers like TO, Subject, however the body content remains blank.!!

I have created a UDF to transform the email content into HTML format. However  I don't see any email Body when a transaction is triggered. The attachment received in email is also received in Blank. ( I am using Message transform bean to convert into HTML UTF charset but that did not helped either).

Any help is appreciated.

Thanks.

Regards,

Nipun

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Aug 23, 2013 at 02:11 PM

    Finally, I resolved the case.

    Here is what I have done in order to get the HTML output from my mail adapter:

    1. Make the XI Mail adapte XSD field ContentType as text/html;charset=UTF-8 ( if you use unicode instead it will not help either)
    2. Make sure to uncheck "keepAttachments" 😊 in the Received Mail adapter.

    Regards,

    Nipun

    Add comment
    10|10000 characters needed characters exceeded