Skip to Content

Make Pb.NET 12.5.2 WPF app run under higher NET FrameWork

Hello, all

I need to know if it is possible to edit config file of WPF app by adding startup->supportedRuntime elements to config file.

I have a data distribution application, which needs to send data to sites with TLS 1.2 and v4.0 does not support that at all.

In a regular .NET app, even when written in v4.0 I can make the app use higher version, by editing the config file.

Is it possible in PB.NET as well ?

Thank you

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jan 12, 2017 at 09:24 PM

    Hi Arcady;

    PB.Net 12.5.2 is (AFAIK) hardwired for .Net 4.0. I an not sure that you can change that ...

    http://pbdj.sys-con.com/node/2496749/mobile

    Regards ... Chris

    PS: PB.Net 12.6 can use .Net 4.5

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 17, 2017 at 06:35 AM

    Thank you, Chris

    I suspected as much

    Secure Black Box is the only solution for me, then. 12.6 is way to unstable to even consider migrating a critical app.

    Add comment
    10|10000 characters needed characters exceeded