Skip to Content
avatar image
Former Member

RuntimeWorkbench Test Message Error when sending message: 401 Unauthorized

I am trying to send a test message from the Runtime workbench and i get the error "Error when sending message: 401 Unauthorized ". My user account has all of the XI admin roles but it still does not work.

All of the Service, Interface, Interface Namespace, User, Password fields I have entered are correct.

We had no problem with this feature on another XI system with SP11. So I am wondering if this is an error with SP12. We have run into two errors with SP12 that we did not have with SP11 on other issues.

Your help is appreciated.

Regards,

Jay Malla

SAP XI Consultant

Licensed To Code

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Sep 23, 2005 at 09:26 AM

    Hi

    I guess the problem should be that your RWB function which sends the message is specifying a wrong client. Try checking the log-files if you find that the HTTP header specifies the wrong client then you will have to change/define the client from which you are sending.

    The way you change the define the client is, in SICF transaction, choose default_host -> sap -> xi -> engine.

    And there you can mention the your client.

    Or you can also forward the client in your url itself, by appending "sap-url=yourclientnumber" to it.

    hope this resolves the problem.

    cheers

    Sameer

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sameer,

      Yes you are right in SICF transaction, choose default_host -> sap -> xi -> engine.

      in the service data tab/Anonymous Logon data is blank.

      So first i tried to append the sap-client=<client-number> in the Send Message To * as follows:

      http://XISERVERhost:<port>/sap/xi/engine?type=entry&sap-client=<client-number>

      and then tried to send the message , message is sent with out error.

      and when i have entered the data in the anonymous logon data tab then with out specifying the "sap-client=<client-number>" in the url again message is sent.

      But now i am facing a issue and it is giving the following error in sxmb_moni and no message is getting display in the runtime workbench message monitoring.

      <?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

      - <!-- Request Message Mapping

      -->

      - http://sap.com/xi/XI/Message/30" xmlns:SOAP=" http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">

      <SAP:Category>XIServer</SAP:Category>

      <SAP:Code area="MAPPING">INITIAL_JCO_RETURN</SAP:Code>

      <SAP:P1 />

      <SAP:P2 />

      <SAP:P3 />

      <SAP:P4 />

      <SAP:AdditionalText />

      <SAP:ApplicationFaultMessage namespace="" />

      <SAP:Stack>All JCo return parameters are initial</SAP:Stack>

      <SAP:Retry>M</SAP:Retry>

      </SAP:Error>

      No how can i resolve this issue.

      Thanks

      Gopesh

  • avatar image
    Former Member
    Sep 22, 2005 at 12:58 AM

    Try regenerating the roles. SU01 -> display each XI user -> open the roles -> double click on the role -> click on the User tab in the role screen then there will be a button for USER COMPARISON do that for all the roles in red.

    If that doesnt work out, Take a look at OSS Note 751856 and 796726.

    May be your security roles were not adjusted during the upgrade (Note 796726).

    regards

    Shravan

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Shravan Miryala,

      I am also facing the same problem. we have SAP XI 3.0 SP9.

      I have also checked the sap notes and also checked the user comparison every thing is fine there.

      But i am getting the same problem in sending a test message from intergration server (component monitoring).

      Do you have any more idea for how to resolve the same issue. One doubt i have whether we can test any scenario using this test message facility for sending the message like if we have used the soap sender adapter for some scenario.

      Is there any problem in XI3.0 SP9 for this test message.

      I am urgently looking for a solution for it.

      Regards

      Gopesh