Skip to Content
avatar image
Former Member

Dispatcher can't start

Hello Guru!

Please help me to solve issue.

I've installed IDM 7.2 (Win2008 R2, Oracle 11.2.0.3, Java 1.6). Client on NW Java 7.3.

In IC I set the Java Options:

When I create a dispatcher and press test I got the following messages:

Running MxDispatcher_<hostname>.

MxDispatcher version: 7.2.8.1 Built: 28.07.2013 18:38:21 (c) Copyright 2008 SAP

AG. All rights reserved.

Java VM: SAP AG   Version: 1.6.0_41

Java home: D:\Install\sapjvm_6\jre

Java lib/ext: D:\Install\sapjvm_6\jre\lib\ext;C:\Windows\Sun\Java\lib\ext

CLASSPATH: D:\usr\sap\IdM\Identity Center\Java\mxdispatcher.jar;D:\Oracle\produc

t\11.2.0\odac_11203_32x\ojdbc6.jar;

[16.08.2013 16:44:10-825] - Reading Db Info - STATEMENT PREPARED: SELECT INFOVAL

UE FROM MC_DBINFO where INFONAME='TYPENUM'

Full dispatcher identifier:<hostname>@<hostname>/<IP>:1376660651044:

10682

Dispatcher identifier prefix:<hostname>@<hostname>/<IP>

No dispatchers with this name (<hostname>) appear to be running!

Cleaning all existing semaphores (starting with null)

In Database in table mc_dispatcher the record with this dispatcher name is exists, but he doesn't see it.

Also I see that there is no any Global Constant and Global Variables in IC (maybe it connects with issue):

Please help me to solve this problem.

Thanks in advance!

Natalia.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 29, 2013 at 12:25 PM

    Hi,

    Your screenshot shows that the dispatcher is running OK. The "No dispatchers with this name () found running" message is confusing, but only means that it didnt find a conflicting dispatcher using the same name already running as a service or on another host. The next line means its cleaned any existing/stuck semaphore locks for its own name so that its ready for processing. Depending on your loglevel you may not see any more information until it starts processing entries or enters an exception.

    As Matt already correctly mentioned, the red errors in your systemlog is due to missing global constants and can be ignored or set. They are usually set when importing the provisioning framework and as such most people would not see this.

    Br,

    Per Christian

    (IdM Development Team, Trondheim)

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 27, 2013 at 05:21 AM

    Hi Natalia,

    This happened to me as well when I upgraded from SP7 to SP8. Dispatcher just wouldn't start.

    This is what I had to do to get it working (not sure if it will work for you but you can definitely try):

    • Un-install Identity Center and Runtime Component
    • In order, Install Identity Center and Runtime Component
    • Restart Windows Server
    • Start Identity Center
    • Create the connection strings  for Idenity Center and Windows Runtime Engine
    • Create the JDBC URL for the Java runtime engine
    • Go to Dispatcher, click Un-install
    • Click on Create dispatcher scripts -> OK -> YES -> OK
    • Click Test
    • And then click Install
    • Quit Identity Center
    • Start Identity Center

    Go your dispatcher, you should see MxDispatcher v7.2.8.0 in the version.

    Now try to Start Dispatcher.

    Let me know how you go. Thank you,

    KV

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 22, 2013 at 12:42 PM

    After I installed dispatcher I see errors in dispatcher logs

    "Error reading global constains":

    I realy do not have these constant in Global constant area, should I add them manually?

    Also I have error in empty job, when I run it (I have 1 dispatcher and use it for this empty job):

    CLASSPATH element '<drive>:\usr\sap\IdM\Identity Center\Java\sapjco.jar' not found!

    And I realy do not have this file in this place.

    What I did wrong?

    Best regards,

    Natalia.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Matt Pollicove

      Matt,

      I created them manually, but it was strange for me, because I have other IDM with SP7, and there is no such problem on it.

      I recreated the database, recreated scripts for dispatcher.

      Now with manually created Global const. there is no warnings about missing constants.

      But this warning still occur:

      CLASSPATH element 'd:\usr\sap\IdM\Identity Center\Java\sapjco.jar' not found!

      I have sapjco.jar on server with IDM SP7, but have no it on SP8.

      Why have it happenned?

      Best regards, Natalia.

  • avatar image
    Former Member
    Aug 16, 2013 at 07:20 PM

    In the Windows Services MMC, what user is set to run the dispatcher?

    I have mine set to Domain\<SID>adm and I think this resolved the problem for me, can you confirm?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 19, 2013 at 06:25 AM

    Hi Natalia,

    In the Help you can find some useful information, about the configuration of your Java Options:

    BR,

    Simona

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Simona,

      it's not clear for me what I have to do with Java options...

      Could you please clarify it?

  • Aug 26, 2013 at 08:11 AM

    Hello Natalia,

    Have you tried to recreate the scripts of this dispatcher? If still the problem, have you already opened a support message to SAP?

    BR, Keith

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 29, 2013 at 02:08 PM

    Thanks all for help with dispatcher testing and installing !

    But this warning still occur:

    CLASSPATH element 'd:\usr\sap\IdM\Identity Center\Java\sapjco.jar' not found!

    I have sapjco.jar on server with IDM SP7, but have no it on SP8.

    Why have it happenned?

    Best regards,

    Natalia.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Krishna,

      I did not update SP7 to SP8, I installed new server with SP8. And there was no sapjco.jar on it after fresh installation.

      But I have other server with SP7 and I have sapjco.jar on it. So I copied this jar from old server to new server.

      Natalia.

  • avatar image
    Former Member
    Sep 06, 2013 at 06:27 AM

    I have copied sapjco.jar from test server with SP7 and it dispatcher works now.

    Thanks all for help and provided info!

    Add comment
    10|10000 characters needed characters exceeded